CIS UI won't open from tray icon - cfp.exe at constant 45%CPU

Title and shots explain most of it.
Right-click ‘open’ from tray icon, no UI appears, cfp.exe runs ~45% CPU until “cleared” by opening CIS UI from the Start Menu.
Rebooting doesn’t help.
Is this a known glitch?

[attachment deleted by admin]

Left the PC overnight. (XP SP3, Athlon II 250 dual core 3.0 GHZ, 2GB RAM)
In the morning CIS UI was open and CPU load back to a few %.
Tried again. Confirmed it takes more than an hour.
Tried “Diagnostics”. No change.
Tried “Repair”. Not possible.

[attachment deleted by admin]

May be left overs of previously uninstalled security programs are acting up. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

Iit seems to be related to Teamviewer 4 resident. More investigation required.

Keep us posted.

It happens only when operating the PC remotely via Teamviewer 4.
Right-clicking the CIS tray icon and initiating/toggling any of the listed actions ‘hangs’ with ‘cfp.exe’ indicating 45% CPU usage .

Attempting to open CIS main UI from a desktop shortcut I created causes only part of the UI to appear onscreen and does not stop the indicated CPU activity (see attached shot).

Opening the CIS UI from the ‘All Programs’ menu item appears to fix the problem. The UI can be now be closed.

[attachment deleted by admin]