CIS UI Fails After Unexpected Shutdown [File attached]

  1. What you did: n/a

  2. What actually happened or you actually saw: I had a power outage so my PC rebooted. Upon getting to the desktop, I got the “Ooops…You’ve discovered a bug” message.

  3. What you expected to happen or see: n/a

  4. How you tried to fix it & what happened: I tried rebooting and running cfp.exe manually (cmdagent seemed to have been unaffected and was running fine as far as i can tell). I even ran the cfpupdater executable in the cis install directory which started up and ran fine (just to test if it would work). cfp.exe just would not start no matter what. i also tried right clicking the cis entry in the control panel add/remove programs and selected ‘change’ but it said cis could not be repaired (the button was grayed out). reinstalling cis corrected all of this.

  5. If its an application compatibility problem have you tried the application fixes here?: n/a

  6. Details & exact version of any application (execpt CIS) involved with download link: n/a

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Not sure if this is consistent.

  8. Any other information (eg your guess regarding the cause, with reasons): I ran ‘sfc /scannow’ which said all windows files were fine. I also ran full chkdsk and it said it found free space marked as allocated in the mft and corrected it (i run chkdsk often and have never gotten that, so i’m sure the unexpected shutdown caused that).

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: n/a

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: n/a

  3. A CIS config report or file. n/a

  4. Crash or freeze dump file: attached

Your set-up

  1. CIS version, AV database version & configuration used: latest version/database

  2. a) Have you updated (without uninstall) from CIS 3 or 4: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  3. a) Have you imported a config from a previous version of CIS: yes
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): many

  5. Defense+, Sandbox, Firewall & AV security levels: D+=paranoid , Sandbox=off , Firewall =custom , AV =stateful

  6. OS version, service pack, number of bits, UAC setting, & account type: 7 ultimate 64, uac off, admin

  7. Other security and utility software installed: n/a

  8. Virtual machine used (Please do NOT use Virtual box): n/a

i’m not sure if this is really a bug, just thought i’d let you know. it was most likely just corruption of some part of cis due to the shutdown.

[attachment deleted by admin]

Thank you for your Issue report in the correct format.

Moved to verified.

Thank you