CIS Tray Icon Disappears and I am unable to launch cistray.exe

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Issue happens intermittently and can only be solved via rebooting.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Like I said it is intermittent and I don’t have a clue as to the cause. The frequency is about once every 48 hours.
  • Any software except CIS/OS involved? If so - name, & exact version:
    No
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Clean reinstall didn’t fix.
    [/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
7.0.317799.4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Autosandbox - Partially Limited, Firewall Custom Ruleset, AV Stateful
  • Have U made any other changes to the default config? (egs here.):
    AV
    Cloud disabled
    Firewall
    Not using Comodo DNS servers
    File rating
    Cloud disabled
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes
    [/li]- Have U imported a config from a previous version of CIS:
    No
    [li]if so, have U tried a standard config - if not please do:
    Yes
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 SP1, UAC enabled, Administrator
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    None
    [/ol]

Please advise on which file(s) to attach; my Comodo logs were full/cleaned since the last occurrence of the issue, so I may have to update the ticket after the next crash/hang/whatever it is.

When you did a clean reinstall did you follow the advice I give here:
https://forums.comodo.com/install-setup-configuration-help-cis/most-effective-way-to-reinstallupdate-cis-to-avoidfix-problems-t58620.0.html
If not then please do try this and see if it can fix this issue.

If you did reinstall by following those methods, but the issue continues, then please wait until it happens again. At that time open KillSwitch and create a KillSwitch Process list (If you are not sure how to do that please feel free to ask).
Also, just after creating this list, run the diagnostics and save the diagnostics report.

You can then attach both of these to your first post.

Thank you.

Was following the clean reinstall procedure, as given in my above link, able to solve this issue?

Thanks.

At this time, as there has been no reply, I am going to assume that reinstalling by following the methods I advise was able to solve this issue. Therefore, I will move this report to Resolved.

However, if reinstalling was not able to solve this issue please let me know and I can move this back to the main bug reporting board for continued processing.

Thank you.

UI crashed again. I took screenshots as I had trouble getting fraps to run. Forgot to install killswitch first/certain I don’t want that software. Pretty unsure it would launch anyway.

[attachment deleted by admin]

Did you ever try a clean reinstall by following the advice I linked to? If not then please try that and let me know if this happens again in the future. It is important to do a clean reinstall, by following those methods, as it rules out many possibilities which must be ruled out before this can be forwarded as a bug.

Let me know if you have any questions.

Thanks.

75 views on this topic would seem to indicate a bug. I might be able to try a clean reinstall eventually; this is a dev machine and those default settings are not going to be very useful. The crash is very intermittent. I think the VirtualBox port forwarding/virtual routing might have something to do with it. Is there a way to back up all Comodo settings before uninstalling?

Before reinstalling you can export your configuration. Then, you can later import it after reinstalling.

However, please do see if this happens with default configuration. If it works fine with default configuration, but after importing the old configuration the issue begins again, then we should have enough information to forward this to the devs.

Also, can you please explain how you think this may be related to VirtualBox? Is CIS being run inside VirtualBox?

Let me know if you have any questions.

Thanks.

Well, it is being run inside there, but it’s working ok in the VM on XP.
The problem installation is on the host machine.
The CIS issue seems to appear around starting up/shutting down VMs, but not nearly consistently enough to be a certainty.

If the problem you are experiencing is on the host machine, and not in the VM, then the VM likely is not playing a role. However, I do want to make sure of something. You haven’t exported a configuration from a different system (meaning running a different OS or inside a VM) and imported it into the CIS installed on the host computer have you? The reason I ask is that the rules for different situations sometimes cause problems if imported into CIS installed in a different system.

Could that possibly be the situation you are facing?

Thanks.