cis stucks wsl [M2319]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
always
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
turn on enhanced protection mode
open windows subsystem for linux
bash.exe stucks with a process called “Init” high cpu usage
One or two sentences explaining what actually happened:
wsl stucks
One or two sentences explaining what you expected to happen:
wsl works as if cis isn’t installed
If a software compatibility problem have you tried the advice to make programs work with CIS?:
?
Any software except CIS/OS involved? If so - name, & exact version:
?
Any other information, eg your guess at the cause, how you tried to fix it etc:
?

B. YOUR SETUP
Exact CIS version & configuration:
?
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
?
Have you made any other changes to the default config? (egs here.):
enable enhanced protection mode
Have you updated (without uninstall) from CIS 5, 6 or 7?:
no
if so, have you tried a a a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
no
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
win10 x64 16299.19
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=? b=?

No issue here. What linux distro is installed? Did you install from the windows store or from lxrun command? And how do you start wsl, do you run bash from the command prompt or do you run the name of the distro e.g. ubuntu? Do you have secure shopping installed?

ubuntu from win store
secure shopping not installed
do you have enhanced protection mode enabled

Yes I use proactive configuration which has enhanced protection mode enabled by default. I assume by stuck you mean it hangs and causes high cpu usage while it is trying to load?

yes

Do you have any other security software installed besides comdo and windows defender? Does you cpu support the vt-x virtualization extension and is enabled in bios options? My CPU doesn’t so if your does then it could be an issue with CIS and WSL attempting to use virtualization extension support of the CPU.

there is no other security softwares
i’m not sure whether vt-x is enabled
there’s no such a issue with cis 6294

Okay I will submit the issue into the bug tracker and see what they say. You may be contacted via PM from a Comodo staff member for more information. Just attach a diagnostic report, thanks.

diagnostic report has already been attached

Sorry didn’t see it thanks.

any updates?

Hi, qweaszxcdf.

Your issue is under investigation. We will let you know results as soon as possible.

Kind Regards,
Sergey.

Can you post a screenshot of CPU-z output like so? I wonder if it is based on CPU hardware virtualization support.

Hi qweaszxcdf,

A Fix will be done soon. We are working on it. Thanks for understanding.

Kind Regards,
PremJK

Any updates?

From Comodo Internet Security v10.1.0.6460 - BETA

- Due to increasing incompatibilities with upcoming Windows RS4 we have removed Enhanced Protection Mode(which was disabled by default) setting from HIPS ; there were advanced methods, which are no longer supported by Microsoft.

Therefore moving to resolved.