CIS - strange drive letters [NBZ]

The bug/issue

  1. What you did:
    After chaging to Custom Policy a pop-up appeared. But I’ve noticed that when i clicked to check what application is it (the active link in the pop-up) a window appeared with error saying like: “Path B:4\LONG_PATH\ is invalid or there is no such a file”. Nevertheless i clicked to create a permanent rule for it. It appeared in rule list and it was working OK (even with B:4.… in path line).

  2. What actually happened or you actually saw:
    Wrong drive letters used for rules.

  3. What you expected to happen or see:
    I expected to see correct drive letters.

  4. How you tried to fix it & what happened:
    I didnt try to fix it. According to unimportant to this matter ocassion i reinstalled windows.

  5. If its an application compatibility problem have you tried the application fixes here?:
    I assume its not compatibility issue.

  6. Details & exact version of any application (execpt CIS) involved with download link:
    None other application involved.

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    It happened to all applications. Even for applications on another drive. AFAIR for usuall drive D: it changed from B:4\ to B:5\

  8. Any other information (eg your guess regarding the cause, with reasons):
    I think the changing drive of letters after installing CIS might have influenced on the CIS itself.

Files appended. (Please zip unless screenshots).
Due to lack of resources this section is ommited.

Your set-up

  1. CIS version, AV database version & configuration used:
    I used CIS 5.3.1814151237
    Why i just can’t copy&paste the number and have to rewrite it?

  2. a) Have you updated (without uninstall) from CIS 3 or 4:
    No, i have not.

  3. a) Have you imported a config from a previous version of CIS:
    No, i have not.

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    I have only changed the Firewall policy to Custom Policy. D+ was inactive due to setting changed while installation.

  5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
    Firewall Custom Policy. Other applications Unactive or unchanged.

  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 Pro PL, no Service Pack, 32bit, UAC disabled, Administrator

  7. Other security and utility software installed:
    Might have installed Avast in the meantime.

  8. Virtual machine used (Please do NOT use Virtual box):
    No virtual machines used.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Post reedited according to the rules.

Could you please add the missing information to your first post.

  1. OS version, service pack, number of bits, UAC setting, & account type:
    Windows 7 Pro PL, 32bit, UAC disabled, Administrator

Thank you


PM reminder sent.

Message updated. AFAIR it was just after installing most major patches with windows update but before SP1 was installed.

Thank you for your bug report in the required format.

Moved to verified.

Thank you