CIS significantly slows upload speed [M680]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes, 100% chance.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Install CIS 6.3.302093.2976. I have installed only Firewall and turned off HIPS, then rebooted.
    b: Upload a large file over FTP (mine was 142MB AVI) using FAR Manager 2.0 build 1807 x86 or go to http://speedtest.net/ (i have used latest Google Chrome for that) and test speed with nearest available node
    [b]c: Upload speed will be limited to 11-15mbits/s. Download speed is normal. Disabling Firewall component does not helps. See also http://www.speedtest.net/my-result/3135510369[/b]
    d: Some other results: Speedtest by Ookla - The Global Broadband Speed Test without CIS installed at all. Speedtest by Ookla - The Global Broadband Speed Test with CIS 5.10 installed.
  • If not obvious, what U expected to happen: Normal upload speed (60+ mbits/s), as with CIS 5.10.
  • If a software compatibility problem have U tried the conflict FAQ?: -
  • Any software except CIS/OS involved? If so - name, & exact version: -
  • Any other information, eg your guess at the cause, how U tried to fix it etc: It is some kind of regression, happened between versions 5.10.228257.2253 and 6.3.302093.2976. As the problem persists even with Firewall component disabled, it seems to be low-level issue with some driver that is part of CIS 6. It is fixable for now by installing older version of CIS…
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.3.302093.2976 (Firewall only).

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Nothing, except Firewall
  • Have U made any other changes to the default config? (egs here.): Yes, i disabled HIPS completely and deleted default Firewall rules then created simple “allow outbound TCP” rules for both FAR and Google Chrome.
  • Have U updated (without uninstall) from a CIS 5?: No, i have never installed CIS on this machine before.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 x32 SP1 (6.1.7601) with UAC off, Administrator account and no Virtual machines.
  • Other security/s’box software a) currently installed b) installed since OS: a=None b=Outpost Pro Firewall (uninstalled completely)
    [/ol]

[attachment deleted by admin]

Please edit your first post so it is in the format provided in this post. This is necessary in order for this to be forwarded to the devs.

Thank you.

I have modified my bug report. Do i required to attach something? I have already uninstalled 6.3 and installed 5.10 instead, so i cannot provide 6.3 diagnostics for now…

Thank you. The format of your report is great.

However, I do need the diagnostic report from CIS 6.3 in order to forward this to the devs. I also need the process list, which can be created with Comodo KillSwitch or another similar program. Please reinstall CIS 6.3 and create these.

Also, did you check to see if just disabling the Firewall component, without uninstalling completely, is able to solve this? If not, please check as that could be very important information.

Thank you.

I have updated my post. Unfortunately, upload speed problem persists even while Firewall component is disabled. Only complete uninstall of CIS 6 fixes this problem. I hope this bug will be fixed soon, it is critical to have full upload speed on broadband ethernet connection.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

well, based on


http://www.speedtest.net/result/3375961919.png

it seems like this problem is indeed fixed in CIS 7.0.313494.4115 :slight_smile:

but unfortunately, it still limits FTP upload speed to like 16mbit/s (2MB/s) maximum, so it is still not resolved. CIS 5.10 still performs better, yielding at least 50mbits/s FTP upload speeds.

Thank you for checking this. I have updated the tracker, letting them know that this appears fixed for normal upload and download speeds. However, for FTP upload this is still slowing down the connection.

Thanks again.

Please let me know exactly which FTP client and FTP settings you are using (ideally the settings file inc whether active or passive connection). Also, please provide any CIS ftp rules and settings, and server details, so the devs can try to replicate.

Thank you.

FTP client is FAR Manager 2.0 build 1807 internal FTP with default settings and the problem is affecting both active and passive connections

FTP rule is COMODO predefined (FTP client)

also i have noticed that the problem is affecting standard browser HTTP uploads too, with both Opera and Chrome browsers (and non-flash based speed tests show significant upload slowdown too, for example TestMy.net Upload Speed Test )

Thank you. I have added this information to the tracker.

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version 8.0.0.4337) and let me know if this is fixed on your computer with that version.

Thank you.

This appears to be fixed in 8.0.0.4337

All tests (FTP, speedtest, HTTP upload) show comparable values to those of version 5.10

Great job, I hope there will be no regression in further versions :slight_smile:

I’m very happy to hear that. I have now closed this in the tracker, and will move this to Resolved. Please respond to this topic if the issue returns.

Thank you.