CIS Setup Wizard has ended prematurely. Your system has not been modified.

I tried to install Comodo x86, and it continues to warn me that the computer must first be restarted to continue. After doing so, I attempted to install Comodo again, Getting close to the end, then a “rollback”, and an error message.

The message reads:
COMODO Internet Security Setup Wizard has ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.

I have searched for this error message, and I have not found any results worth reading. I have not installed Comodo previously, this is the first time. I don’t know how to “Modify” the system. I am the only user on this computer, and I have fairly sure I am an administrator. If I need to be, I will check.

Any help is very much appreciated.

Do you have the sptd driver present? Used in Daemon Tools, Alcohol 52% and other programs.


No, I don’t have either of them. Honestly, I’m not even sure what those are.

I tried to update my comodo firewall, but it said I had to uninstall my previous version, which i did. Then when I tried to install the firewall, I got about halfway then I got an error message - setup ended prematurely your system has not been modified.
Anyone knows what the problem may be???

Is this the 1603 error? If so check out the following topics with clues and see if they help you any further:

Thanks for your reply. I tried the cleanup tool - a batch file - mentioned in the link you provided and then was able to install the firewall.;msg259617#msg259617