CIS sending data without permission?

I disabled the enable cloud lookup option but Comodo CIS appears to be trying to do it anyway. I get firewall alerts when I run a program that CIS hasn’t seen before. How do I stop CIS from sending info to Comodo?

I think that I found the problem. In Windows Task Scheduler there is a task called COMODO Telemetry. I don’t recall agreeing to have telemetry sent to Comodo. I like free software but not having data sent that I don’t think I consented to sending. I don’t see anything in the CIS control panel that informs the user that this telemetry is being sent or gives the user the option to disable it.

It’s under the Logging section in Advanced Settings . . . as attached

I looked at that setting and it is disabled in my CIS. The telemetry task was active anyway.

There’s a whole thread on it here, which explains the workings of the Task:;msg875686#msg875686