CIS seems to block Firefox window

Hi,
i’m using CIS 5 for some days now and all went well. But today i can’t start firefox anymore
(i’m aware that firefox can need some minutes to start). After clicking the icon, the typical sandclock is shown for a second and nothing happens anymore, however taskmanager is showing firefox.exe running.
What i’ve tested so far:

-safemode not working either
-checked Mozilla help sites and tested everything given
-deleted FF profiles
-complete deinstall of FF and reboot
-cleaned with CCleaner and Registry Cleaner
-tested reinstalls of FF 3.5.14, 3.6.11, 4.0 beta 6
-deinstall Adobe Flash
-deinstall Java
-deinstall GesWall
-defined FF as “trusted” with profile “Webbrowser” in Firewall-menu
-defined FF as “trusted” with Defense + -menu

after uninstalling CIS5 Firefox was starting fine again ?

Now i’m running out of ideas…
thanks for your help

regards,
gam

I have no solution how to fix your problem but I think you could try comodo dragoon or google chrome. I use for instance Comodo dragoon(it’s based on google chrome); it’s fast and good.

Regards,
Valentin

Hello gambla; Welcome To Comodo Forums

What ver, of CIS do you have?
CIS > More > About

Hi Jacob and Valentinchen,
it’s version 501636521142.

Can you check the following places

CIS > Defense+ > Computer Security Policy
Check What Firefox is list under as and also Plug-In container
C:\Program Files\Mozilla Firefox\firefox.exe and Also plugin-container.exe
What policy they are treated as

and then head over to “Always Sandboxed” see if Firefox/Plugin Container is there
if not then head over to blocked files once done report back if you may…

did this help?

Firefox is treated with “Custom policy”. The plugin-container is not listed here.
And they are not sandboxed or untrusted.

thanks

The plugin container is only useful for some plugins (Flash…).

Assuming Mozilla is not a trusted editor, FF defense+ allowing rules are as follows:

Firefox.exe:
-run an executable: path of FF
-interprocess access: explorer.exe
-protected COM interfaces: \RPC Control\spoolss
-protected files: \Device\Afd\Endpoint

Explorer.exe:
-run an executable: path of explorer.exe

On the firewall side, TCP out ports 80 and 443 must of course be allowed.

It’s weird, FF only works sometimes after a reboot. But after closing the window and restarting ff, it again doesn’t open the window, only the process is running. I deinstalled CIS again and ff works perfect. And it runs fine with Sandboxie. More testing done:

  • Starting in safemode or profile-mode doesn’t work.
  • I think i have tested every possible settings in defense+ and firewall but seems to have no impact.
  • Could test it without addons, doesn’t work.
  • Deinstalled Java, doesn’t work.

Any help strongly appreciated.

you should not run two sandboxes at once.

Regards,
Valentin

Are you sure Geswall was completely uninstalled? Try the following mini tutorial to look for left overs of Geswall or other previously installed security programs.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.