CIS says " Network firewall not working properly " on startup

I am currently using Comodo Internet Security 5. Its been working propery but now on startup it says " Network firewall not working properly. Run the Diagnostics utility to fix the problem ". So i run the diagnostics utility and it says " The diagnostics utility did not find any problems with your installation ".

So i closed the program and launched it from desktop shortcut. BUT NOW IT WORKS. So i restarted windows and it again said " Network firewall not working properly ". When i close the program and start it manually it works.

I am using windows 7 32-bit.

Please help me folks…

Note: I already tried uninstalling and reinstalling…also used cleaning utility to remove left overs that didn’t help either…

Hey and warm Welcome to the forum!

Do you have other firewalls that are active? have you had other internet security software installed on your pc before you installed CIS?

Merry Christmas

Valentin N

thanks :slight_smile:

no i have no other firewalls or AVs installled also i didn’t installed any other security apps installed before comodo.

When it says " Network firewall not working properly " can you see if cmdagent.exe is running with Task Manager? Make sure you have “Show processes of all users” enabled in Task Manager.

yes the cmdagent is running…

Do you have program installed that interfere with networking like Net Limiter, VPNclients, IP filters like Peerblock/Peerguardian etc…? Try disabling them one by one and see if that solves it or not.

no i haven’t installed anything

do you have other information that might be useful for us to know?

Valentin N

Best thing to do to make sure that there are no left overs of previously uninstalled security programs around. Not all uninstallers do a proper job. And left over applications, drivers or services can cause all sort of “interesting effects”.

Following are two of my tutorials to make sure there are no more left overs.

Use existing removal tools

Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

For a more technical hands on approach:

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. First run "set devmgr_show_nonpresent_devices=1’ without the quotes from the command prompt.

Then go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer. You need to Google the driver’s names to see to what programs they belong to. You don’t want to uninstall Microsoft/Windows related drivers of course; some Microsoft drivers may show up as non active please don’t uninstall them. It is best to make a system restore point before this of course.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

i already tried uninstalling and reinstalling as you said.

sometimes comodo starts normally, some times it won’t.

i am losing patience… :cry: …but i love it…

please help mates… :cry:

I am sorry if I sound ignorant but try to reinstall it for the last time this way (reinstalling something can be the best way of solving a problem): Download CIS 5.3 32bit Premium and CIS clean-up tool. uninstall the current CIS, use the CIS cleanup tool in safe mode (that you through pressing F8 when the computer boots) and install CIS 5.3

I hope this help and it if doesn’t means that you have found a bug.

Valentin N