CIS pro not updating signatures

A. THE BUG/ISSUE (Varies from issue to issue)
CIS pro is set to automagically update signatures etc. whenever sth new comes available, but it doesn’t perform that. After some time (2…3 days or so) cistray.exe shows an orange bar with the german equivalent of “vulnerable”. I’d have to click it to open CIS and manually trigger a signature update.
Can you reproduce the problem & if so how reliably?:
Auto update seems not to happen persistently.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. CIS set up to auto update (since long time)
  2. Booting up PC about 3 days after last signature update.cistray gets up and tells “vulnerable”.
    One or two sentences explaining what actually happened:
    CIS refuses to auto-update signatures.
    One or two sentences explaining what you expected to happen:
    Auto update of signatures.
    If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:
Don’t know …
Any other information, eg your guess at the cause, how you tried to fix it etc:
?

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Internet Security Pro 8.4.0.5.5165, licensed.
Signaures version 26232
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus: Intelligent
Auto-Sandbox: ON
HIPS Safe mode
Viruscope ON
Firewall Secure mode
Game Mode OFF
Have you made any other changes to the default config? (egs here.):
Don’t know, but not much of it besides allowing applications to run.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
I think I’ve uninstalled prior to installing the current version.
if so, have you tried a a a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
Unsure … but I think no.
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting: Standard (2nd from top), account type, V.Machine used:
Win 10 pro x64 (updated from 7) current patchlevel, UAC, admin level account, no VM (but MMWare WS 12 installed)
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=
Windows Firewall = off
Windows Defender = off
b= unsure