CIS Pro does not work after upgrade on Windows 8.1


I upgraded windows 8 to 8.1 yesterday and my CIS Pro stopped working. I uninstalled it and reinstall again. CIS works except firewall.

It writes this error:“The network firewall is not function properly!”.

  1. I wrote to Comodo support I was told it does not work together. Here on forum I read it works to somebody.
    So how is it, does it work or not?

  2. I cannot run this

You can return CIS into working state running the diagnostic manually: please run following command in CIS working dir, typically "C:\Program Files\COMODO\COMODO Internet Security": cis.exe --diagnoseUI

Can anybody advice me or do I have to wait for another Comodo version?

thank you

If you had upgraded, and had not already uninstalled CIS, I would have advised you follow the advice of Slava Garelin here:

However, as you have already uninstalled, that will not work. Thus, my advice would be to reinstall CIS by following the advice I give here. Be sure to run the CIS removal tool which plays well with Windows 8. Also, run it in Safe Mode.

Let me know if that helps.


I also upgraded to Windows 8.1 yesterday and CIS stopped working completely, especially Defense+ component. The diagnostics did not help at all. So I uninstalled CIS, restarted PC and reinstalled CIS, restarted PC and after that everthing works fine…
Try reinstall CIS again. Hope it helps

I upgraded from w8 to w8.1 with installed CIS, I did not know I had to uninstall it first. CIS did not work after upgrade. I uninstalled it and reinstall again and still it does not work. It writes what I wrote above in the first post.

Then I downloaded this CIS+Removal+Tool+2013, run as administrator and installed CIS again. I still have the same error. FW does not work.

As I wrote I do not know how to run the advice from Slava Garelin. I tried to run this “C:\Program Files\COMODO\COMODO Internet Security\cis.exe” /diagnoseUI and window from CIS shows but the same error is still there.

I reinstalled CIS for about 3-4 times. Diagnostic does not help me either. Stops working in 65% and then writes it does not work.

Did you run the CIS+Removal+Tool+2013.bat file in safe mode?

No. I will try it now.

I did it in safe mode but it still does not work. I have still the same error. And now I do not have the network in firewall settings.

After uninstalling and running the removal tool in Safe Mode restart the computer. Then manually make sure that the CIS network driver is removed. If you need instructions for how to do this they are given in my other topic.

I do not know where to look for CIS network driver. I do not have it in Plug and Play in device manager. I showed hidden device.

Can you please upload a screenshot of what you do have? Sorry, I don’t have Windows 8.1 and therefore am not sure exactly what to look for.

Of course, but I do not have it in English.

[attachment deleted by admin]

I have this problem solved. It is very easy. I did it when I have CIS installed. I did not uninstall it. I changed it in the regdword. Run fix in CIS (maybe it is not necessary). Restarted PC and it worked.

It is enough to do this:


Run regedit, go to this value
On the right side you will see MaxNumFilters REG_DWORD change it’s value from 1 to 8. Reboot your machine and then install Comodo internet security and if you already did , Do it again.

If you don’t have the above DWORD, you can simple create a new one by right click selecting New \ DWORD name it MaxNumFilters and change it’s value to 8.

This is very interesting article Redirecting

[attachment deleted by admin]