CIS Pro 2012 installed - can't open pdf's from Thunderbird message

Ever since installing Comodo Internet Security Pro 2012, I can’t open pdf files directly from a Thunderbird. I get an error message that says, “Windows cannot access the specified device path or file. You may not have the appropriate permissions to access the item.”

Pdf’s from e-mail messages open just fine in Outlook.

I get a second error message in the Thunderbird download window that says:

"C:\Users\Ken\AppData\Local\Temp\doc20120227151137.pdf could not be saved, because you cannot change the contents of that folder.

Change the folder properties and try again, or try saving in a different location."

When I go to that folder in Windows Explorer, the file is there and I can open it just fine.

Additionally, GeekBuddy doesn’t seem to want to run on my machine.

Just discovered that it is not just pdf’s but any attachments won’t open and I get the message saying I don’t have access to the temp folder.

Following links from e-mails also is not working.

Again, this all started when Comodo was installed.

Can you provide some additional details please. The settings your using for CIS, the version of thunderbird and the location of the thunderbird mail folder.

CIS settings:
Antivirus - Stateful
Defense+ = Safe Mode
Firewall - Safe Mode

Thunderbird 10.0.2

C:\Users\Ken\AppData\Local\Thunderbird\Profiles &
C:\Users\Ken\AppData\Roaming\Thunderbird\Profiles\embs41eb.default\Mail\Local Folders

I’m not sure the above is quite what you’re looking for. I set three accounts up as IMAP so that the messages stay on the servers (gmail, yahoo, etc). If I have a message that I want to save, I drag and drop it to a local saved folder (the second entry above). MOSTLY though, I read and delete out of the IMAP servers.

I’m not able to reproduce the thunderbird problem. I personally use tb daily builds (13.0a1) but I installed 10.0.2 on a test machine and sent a few emails with different attachments. Using the same settings you mentioned for CIS, all attachments opened correctly. Here’s a couple of things you can try:

  1. In thunderbird, go to Tools/Options/Attachments and check the settings
  2. Check the permissions on the Temp folder
  3. In D+/Computer Security Policy - make sure thunderbird is allowed to run your reader (image)
  4. Create a new profile

However, the fact you can’t seem to get Geekbuddy to work, suggests you may have some additional problems. The first thing to try is running a Diagnostic - Comodo/More/Diagnostics

[attachment deleted by admin]

Changed TB in Comodo to a trusted application. I could not see the Customized Settings you showed unless I went into the Predefined Policies tab.

Once I changed it to a trusted application, links and attachments open just fine.

I did the same thing with Firefox (changed it to trusted application) and it still seems to be having problems playing flash movies (YouTube, etc). The sound is there, but no video. This is after reinstalling Adobe flash player. Perhaps I should install it again after I’ve changed Firefox to a trusted application.

Meanwhile, I ran the diagnostics on Comodo and it came up with nothing. It found no problems with the installation. Geekbuddy still won’t run.

You really shouldn’t need to set applications like your email client and browser as ‘Trusted’ especially if you’re running in ‘safe Mode’. In Fact, in ‘safe mode’, you shouldn’t have to do anything at all, as the products we’re talking about are all on the Trusted Vendors List and hence are ‘Trusted’ applications.

Any idea what’s going on with GeekBuddy and flash movies (

With Geekbuddy there should be no problems. However, I’ve never actually used the service and when I just installed CIS on a test PC ,with Geekbuddy enabled, apparently ‘My Trial’ has expired. So someone else will have to help you with that.

With regard to, again no problems with a default install. Do you have any additional security products installed?

[attachment deleted by admin]

I also run SuperAntiSpyware. I actually installed it first, and did not encounter any problems.