CIS prevents game .exe from running

With latest version of CIS (antivirus of CIS is disabled, using the “+” option of firewall), Supcom Forged Alliance refuses to run.

If I keep trying to run the .exe of FA, eventually it will run.

Tried uninstalling CIS - FA runs properly. CIS is the newest as of Feb23, 2009, fully updated. An older version of CIS from last month worked just fine. It is a new installation of Windows XP SP3.

Any ideas why this is happening?

As Games and Alerts don’t go to well together the suggestion is to run the game once with FW and D+ set to “training mode” this will “learn” the game, after that you should be able to switch back to the mode’s you are running now.

I should have been more clear: there never was any popup windows when trying to run the game. I put that application as “trusted”, so there should have been zero interference from the firewall

Was something majorly changed with CIS in the last 2 weeks?

Yes there have been, and there is also a nasty bug in D+ could be your having trouble with it, i expect a new release this/next week to fix it.