CIS Premium 5.3 AV scanner crashes

CIS Premium 5.3 AV scanner crashes while scanning some RAR achives. Cannot determine what is the cause for it. CIS 5.0 did very well on my environment with the same files na disc structures. It happens on full system scan, and also when context menu is used to scan the particular file.

Sometimes there are not enough system resources to complete the task, and sometimes the scanner just dissapears - both without completing the scan.

With the new release Comodo broke something that already (always) worked fine. Great! :-/


The bug/issue

  1. What you did: (first) performed fullscan of my system and (second) choose particular files to scan with context menu
  2. What actually happened or you actually saw: (first) the scanner freezed and system showed that there are no enough system resources to continue (second) the scan window dissapeared each time it was used on some files
  3. What you expected to happen or see: the scanning result window with summary and close option
  4. How you tried to fix it & what happened: tried to scan more than once, no result
  5. If its an application compatibility problem have you tried the application fixes here?: no
  6. Details (exact version) of any application involved with download link: lates Comodo CIS
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: scan my system
  8. Any other information (eg your guess regarding the cause, with reasons): till the 5.0.163652.1142 version my files were scanned correctly

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:-
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:-
  3. A CIS config report or file.-
  4. Crash or freeze dump file:-

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.174622.1216, nevest available 7253
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no (clean install after deinstalling 5.0.163652.1142)
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: -
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: -
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= default , Sandbox= default , Firewall = custom rules , AV = default
  6. OS version, service pack, number of bits, UAC setting, & account type: win xp sp3, 32 bit, no UAC, admin account
  7. Other security and utility software installed: none
  8. Virtual machine used (Please do NOT use Virtual box): none

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Dennis

The bug/issue

  1. What you did: (first) performed fullscan of my system and (second) choose particular files to scan with context menu
  2. What actually happened or you actually saw: (first) the scanner freezed and system showed that there are no enough system resources to continue (second) the scan window dissapeared each time it was used on some files
  3. What you expected to happen or see: the scanning result window with summary and close option
  4. How you tried to fix it & what happened: tried to scan more than once, no result
  5. If its an application compatibility problem have you tried the application fixes here?: no
  6. Details (exact version) of any application involved with download link: lates Comodo CIS
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: scan my system
  8. Any other information (eg your guess regarding the cause, with reasons): till the 5.0.163652.1142 version my files were scanned correctly

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:-
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:-
  3. A CIS config report or file.-
  4. Crash or freeze dump file:-

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.174622.1216, nevest available 7253
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no (clean install after deinstalling 5.0.163652.1142)
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: -
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?: -
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): no
  5. Defense+, Sandbox, Firewall & AV security levels: D+= default , Sandbox= default , Firewall = custom rules , AV = default
  6. OS version, service pack, number of bits, UAC setting, & account type: win xp sp3, 32 bit, no UAC, admin account
  7. Other security and utility software installed: none
  8. Virtual machine used (Please do NOT use Virtual box): none

I’ve made some testing, and have the main cause. The issue mentioned has something to do with the PATH LENGTH for the files being unpacked in the background, while scanning archives (zip, rar, mht, etc.).

I’ve got the same problem. But it doesn’t matter what is scaning archive or exe file. Full scan doesn’t work till end.

Hi Shirka,

The post alone does not help us to reproduce this issue but you can help us reproduce:
1 - You said you can reproduce this when you scan a particular file with right click scan. Can you please attach that file?
2 - Can you please show the FULL path of the file in your system so that we can create exactly the same scenario?

Thanks,
Egemen

Please find the example file attached to the post. You can place the file in the root of your drive, and try to scan it with the right click. The scan will fail, at least for me it fails. The scan crashes on one of the files contained in the mht file inside the archive. if you unpack the mht file to the root of your drive - the file will be scanned correctly with the right click function.

Previous versions of CIS (till 5.0) were doing fine with that kind of files. I am wondering - were they scanning that file, or were they omiting it? The second explanation would not be good I think. Can you explain why previous versions were not having any problems with long paths?

[attachment deleted by admin]

Thank you very much. I have successfully reproduced this issue. Will be fixed asap.

Can you please report back if the latest Program update has fixed this.

Thank you

Dennis

As you have not reported back after 14 days, I presume the bug is fixed.

If not please post in this topic and I will move it back to the Bug report board.

Moved to resolved.

Thank you

Dennis

My complete scan crashes furthermore.