CIS Premium 10 and git for windows

Hi,

After the last update, my gitbash isn’t working as it expects.

http://s6.postimg.org/96s2xs5ch/screenshot_2017_04_07_at_18_11_34.png

I unblocked all blocked files, disabled all CIS, but gitbash won’t work. If I uninstall CIS, all works as before.

Help, please.

They’re aware of the issue. Here’s a workaround : Reply #65.

Thank you very much!

Disabling all advanced protection helped. (■■■■)

I have been a user of CIS 8.4 under Win7 for a long time. Cygwin, Jetty/Java, Mysql, and other applications ran fine.

Then I upgraded to CIS 10.

The mintty/bash of Cygwin won’t start anymore. Apparently, some DLL cannot be loaded. Which, I can only guess. There is nothing in the CIS logs.
Jetty does not start anymore properly. There seems to be an issue with either Java or the allocation of port 443 (https).
Mysql seems to have made it into the CIS 10 world, but from time to time I keep getting alerts about incoming connections despite having configured that already as allowed (from my local network).

It won’t work properly with a fresh install (new configuration) and it does not get better with the old configuration imported.

Adding Cygwin binaries to the trusted file list takes forever and the entire system hangs. After having computed the list of files (78.000 something), I try to add them to the trusted list… and Comodo goes to sleep… it ran over 8 hours without result.

The deinstallation of programs fails when CIS 10 is installed, including the deinstallation of CIS 10 itself. After several attempts and a few manual fixes of directories and the registry, I managed to fully get rid of CIS 10.

Something is seriously wrong here. Time to switch to a different firewall/antivirus product?

–gandalf.

PS: And CIS 10 also blocks audio output (no idea why) and gives me a black screen from time to time… no fun.

See: Reply #65. It’s a known issue.

After update to version 10.0.1.6209 Git Bash (https://git-scm.com/) doesn’t work. I try to stop Comodo, try to stop all Comodo services, but Git Bash won’t start correctly.
I try to reinstall Comodo and Git Bash, but I have no success with Git Bash. Git works only when Comodo is uninstalled.
Error in Git Bash:
0 [main] bash 9408 fork: child 8384 - died waiting for dll loading, errno 11
bash: fork: retry: Resource temporarily unavailable
1052788 [main] bash 9408 fork: child 6248 - died waiting for dll loading, errno 11
bash: fork: retry: Resource temporarily unavailable
3177123 [main] bash 9408 fork: child 7460 - died waiting for dll loading, errno 11
bash: fork: retry: Resource temporarily unavailable
7232873 [main] bash 9408 fork: child 11504 - died waiting for dll loading, errno 11
bash: fork: retry: Resource temporarily unavailable
15317862 [main] bash 9408 fork: child 4836 - died waiting for dll loading, errno 11
bash: fork: Resource temporarily unavailable

see this post for workaround https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-v10016209-released-t118704.0.html;msg854022#msg854022

Highly obscure but it seems to work for me for the time being… the same seems to cure the audio issues I was having.
Looks like CIS 10 can use a bit more QA before it should hit the road.

Thanks to all who helped!
–gandalf.

Please elaborate on the audio issue. :slight_smile:

The audio issue was actually a “no audio” issue :wink: I did not see a log entry that anything was blocked or disallowed to operate. There was simply no sound in or out. Reboots did not help, and allowing these applications to do whatever is possible also did not fix the issue.

As soon as the bash problem was resolved, audio also worked again (e.g., in Skype, Viber, VLC Player, Windows Media Player).

Cheers,
–gandalf.