CIS password with spaces [NBZ]

The bug/issue
1. What you did:
open the main window of CIS, MORE->Preference->Parental control->change password->I entered my password, for example, it was "test " (please notice that there’s a space in it), re-entered it->Apply

2. What actually happened or you actually saw:

After I applied my password, nothing happened, which may mean this password is valid and successfully configured. BUT after that, when I try to login to the preference window with my password, I input it correctly many times, but it says “invalid password” showing that i didn’t input it correctly.
And what’s more, some other ones DID suffer from this bug, and they believe that it was the problem of “space password”.

3. What you expected to happen or see:

space could become a valid character for password, or an alert that can’t use spaces in password.

4. How you tried to fix it & what happened:
I edited the reg:

HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\Settings\PasswordEnabled
to 0, and
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\Settings\PasswordHash
to 00 00 00... to reset my password. And restart my PC.

5. If it’s an application compatibility problem have you tried the application fixes here?

6. Details & exact version of any application (except CIS) involved with download link

7. Whether you can make the problem happen again, and if so precise steps to make it happen
Yes, do as Entry 1 said.

8. Any other information (eg your guess regarding the cause, with reasons):
password with spaces in it

Files appended

Your set-up

1. CIS version, AV database version & configuration used:
5.3.181415.1237, AV satabase 8267, “COMODO-Internet Security” configuration.

2. a) Have you updated (without uninstall) from CIS 3 or 4:
b) if so, have you tried reinstalling (if not please do)?:

I installed 5 directly.

3. a) Have you imported a config from a previous version of CIS:
b) if so, have U tried a preset config (if not please do)?


4. Have you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.):

5. Defense+, Sandbox, Firewall & AV security level:
D+=clean PC, Sandbox=Disabled, Firewall=Safe, AV=Stateful

6. OS version, service pack, number of bits, UAC setting, & account type:
Windows 7, SP1, 64 bit, UAC=“Notify me only when programs try to make changes to my computer (do not dim desktop)” level, Admin account.

7. Other security and utility software installed:

8. Virtual machine used:

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


I’m sorry that I didn’t follow the format.

Thank you for your kindly suggestions.

I edited it and hope it works.

Thank you for your bug report in the required format.

Moved to verified.

Thank you