CIS or firefox problem

Hello all :slight_smile:

Having problems in firefox with websites hanging etc. Do you think this is just a browser issue?
Or do you think this could be a firewall issue.

I know this is a bit vague, but i have reinstalled frirefox, changed numerous setting, changed my dns in router. Nothing seems to be different.

I don’t want to take the easy way and reformat as i will not learn anything.

Any advice would be appreciated.

I have Comodo Internet Security Premium


=Hello inthedark :smiley:

Let me shed some ‘light’ on this issue;

Could you list your CIS version as well as OS and possibly RAM / CPU stats
Also CIS configuration? (Safemode/Paranoid Mode etc etc)


Hello Jacob

CIS : 5.0.162636.1135, vd :7353
OS : Vista Home Premium
RAM : 4gb
CPU : Core2duo E8400 3ghz
Av : on access
D+ : safemode
FW : Safemode


Is firefox the only app that is being affected atm?

Have you modifed any the settings in CIS?
Also; I would leave the DNS in your router alone/set to defualt unless you have a service that you are using that requires such change


Hello Jacob

Changed dns after running namebench, current dns was slow.
Downloaded Chrome, Opera to see if better than firefox, Opera exhibits similar behaviour as firefox, websites hanging etc. Not really tried Chrome.

Not made any changes with Comodo



Try 1:
go to Start > Run > Cmd >
ipconfig /release
icponfig /flushdns
ipconfig /renew

Try 2 If First doesn’t work
Could you try switching your router back to original settings
and change DNS by changing the IP Properties of your computer?
and try changing them to Comodo SecureDNS and see if it still slows down


Hello Jacob

No1 did not work.

  1. Reset original dns

change DNS by changing the IP Properties of your computer?

How do you do this. Am i changing IP to comodo which will auto discover DNS?


No, change only DNS to address provided by your ISP. If you haven’t noted it, you can enable “Obtain DNS server address automatically” option or try Comodo DNS. Here is explained how to do that.
Also, check your hosts file that is located in the following directory: C:\Windows\System32\drivers\etc\hosts. Open it with Notepad and upload a screenshot of it, so we can see if there is something wrong with it.

Hello Deadman

What is it that i should be looking for. I have a long list from Spybot.


The hosts file should look exactly like this:

# Copyright (c) 1993-2009 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
# For example:
#          # source server
#              # x client host

# localhost name resolution is handled within DNS itself.
#       localhost
#	::1             localhost

There must be no extra websites listed.

What’s your security setup right now?
S&D is not good anymore. You can uninstall it, install MBAM and run a scan to make sure that this problem isn’t caused by some kind of malware.

If you’ve used the “Immunize” feature in Spybot, your HOSTS file is filled with ■■■■.

Large HOSTS files are not recommended because they cause system performance issues. This is because the HOSTS file is not an indexed file. So each website you visit, your system must read the HOSTS file from the beginning each time to see if a site is listed or not. If your HOSTS file is large, you can see this would adversely affect performance. I can’t remember the size, but I think you can start noticing slowdowns if the file is larger than 250kb.

Some sites that supply large HOSTS file lists recommend disabling the Dnscache service to avoid this slowdown. The net effect now is that your DNS entries aren’t cached locally. This will slow down your browsing because each and every URL now triggers a DNS lookup because it can’t use cached results.

I would definitely recommend not using the “immunize” feature for this very reason. Spybot will have made this file read-only, so I would clear the read-only flag and delete the countless entries Spybot has added to your HOSTS file.

Hello HeffeD

I’ve uninstalled spybot. Uninstalled firefox, loaded an earlier version still no change. I have a spare router, i think i might try that.

Do you think a faulty router could cause these problems also.


I don’t know that uninstalling Spybot will remove entries from your HOSTS file. Have you checked it?

Can you please copy and paste log from HiJackThis here?

I doubt it. If the router is failing, you should notice problems with applications other than Firefox too.

Yes it still has lots of Spybot entries, how do i delete these.


The easiest way is just to create a new one.

Details here.

How do I reset the hosts file back to the default?