CIS not updating: error 0x80072efd

I uninstalled COMODO Internet Security since the no-update issue still isn’t fixed …
Running on Win 10 Pro and when I try to update all I get is a 0x80072efd error (could not connect to server) ??

Clean CIS installation recommended if you installed Windows 10 from Win7 or Win8. This may cause the problem.

Have made a clean install (uninstalled the previous version)…
But the last versions of CIS gives me the same error.
Is there a Comodo Uninstall All program that I can use ???

There is no uninstall tool for Comodo products.
You can follow this guide without installation section : Comodo Forum

ok, did as the uninstall post said but still no go …
Same update error 0x80072efd (no server connection) and when i try to update the antiviruspart of CIS it goes to 2.5% and then just dies (scanning interrupted ??)…
So I will continue to use other (working) security software until this is fixed (to bad, I really like Comodo)
btw, I am running on Win 10 Build 10240 if that helps (upgraded from Win 7)

I have same error in windows 7: 0x80072efd