CIS not appearing on windows startup?

Did I miss something? Did something change?

Last thing I knew…CIS Premium (Free) I recalled started up on it’s own for windows 8.1 and now I noticed it doesn’t start itself up anymore yet I can see a few background processes.

What happened? I looked for preferences to enable it on startup but I don’t see anything. I’m guessing something changed and it’s not free anymore? I guess that got turned into a Pro Paid Feature maybe or something?

It should start up by itself when Windows starts. Please try reinstalling by following the advice I give in this topic and let me know if that solves this problem.


i did fresh install downloading latest updates and installed comodo firewall…it dosen’t show up automatically anymore maybe latest windows updates (win 8.1) have something to do whit that

now i need to clik desktop icon to get it running :confused:

investigate and fix it o/

Did you follow the advice given in the guide here, including booting into Safe Mode and running the removal tool? If not please do try that. Often a normal reinstall will not fix a problem like this, but following those steps will.


i mean i format my c: installing windows 8.1 and update it and firewall after that and it not worked like it should (no icon on taskbar) now i need to manually kick it running

Are there any other software running alongside it (even if you don’t think they could be causing problems), or does this happen even when it is a fresh OS and CIS is the first program installed?

On the windows startup comodo is launched but not the interface ^^
I have the same bug i have just go to regedit and re-create a stratup key for Cistray.exe
I hope a fix will be released !!

it happens when a fresh OS and CIS is the first program installed nothing else installed before those


yea thank you that fixed it :slight_smile:

Format, install W8, update to 8.1 from store then install firewall. Doesn’t load at start-up (only firewall installed, nothing else).
Format, install W8, install CF then update to 8.1 from store, everything works as it should and firewall loads at start-up after update.
Bloody waste of time.

I’m getting this same issue on one of my machines, should I create a bug report? Everytime I install CIS on it, Comodo will not create a startup key, meaning the tray icon never shows for me.

Ok, I created a bug report for this since I’m getting this issue repeatedly on my machine. Here is link to it:

This worked for me:

  1. Go to a PC running Windows 7 with Comodo
  2. Run regedit
  3. Export the startup registry key for Comodo
    (HKLM\Software\Microsoft\Windows\Current Version\Startup)
  4. Put the .reg file on a flash drive.
  5. Double-click the .reg file after inserting the flash drive into your Win 8 PC
  6. Reboot → You’re good to go!

You can use this fix by qmarius. It will add the start entry to Task Scheduler where it is intended to be. When CIS is on a non standard path you need to edit the xml file to match the path.

I found this to be the easiest fix. I just placed a shortcut to cistray.exe in the startup folder.

Open, “Run
Type, “shell:startup” and press enter.
Open a new window and navigate to, “C:\Program Files\COMODO\COMODO Internet Security” and right click, “cistray
Right click on it and hover over, “Send to” and click. “Desktop (create shortcut)
Now just drag and drop the shortcut that was placed on your desktop into the startup folder and restart your PC.
CIS should now load the tray icon.

When Comodo is installed, a very specific path is added in the startup entries that includes a guid string… if you use a startup manager (Yamicsoft’s Windows Manager, for example), you’ll immediately notice the difference for the Comodo entry.