CIS keeps deleting software during startup.

I Don’t know why I’m even posting… It certainly does not seem like anyone really uses this forum, certainly not any Comodo staff.

The trouble I have when trying to use CIS is that every day when my computer boots up I see a message on the screen during boot informing me that CIS is forcing file deletion. And deletion it is… usually about half of the work I put into getting my flight simulator back up and running has been deleted.

Not uninstalled mind you… just deleted. Entire program folders, indevidual aircraft folders, etc.

I do not use the sandbox.

I even turned off autosandbox just to be sure.

I tried installing software by using the Comodo Programs Manager.

On several installers I was asked (by CIS) the first several times I ran them weather or not I wanted to allow full rights to the installer.

I can’t even tell exactly what is deleted except by looking for it since it seems to keep no record (that is available to be) of what it deleted during boot up.

So far it has destroyed my FSX by deleting updates and addons after they were installed and integrated, deleted 56 windows updates after they were installed, at least the Outlook portion of MS Office 2013 (and who knows what other office programs… I have not checked yet)

Uninstall CIS and the problem stops, reinstall CIS and the problem comes right back.

And by the way… CIS was the first application installed after drivers and windows updates on a fresh OS and a new Hard drive.

If anyone can shed some light on this I really wanted to give CIS a try. I have been using AVAST for years and find it more and more lacking every time they update it.



from the top of my head I could think of a reason for that.
Do you have trainers? They get deleted by CIS (false positive).
Do you have third party software for your flight simulator?
The software could have some Virus like behavior so it get’s deleted.
Is it original software or cracked software? If cracked the executables and sometimes *.dll’s get deleted…
You could add the folder of your FS to the exclusion list of the AV so it wouldn’t care what happens in that folder…



Looking at the defense+ and antivirus logs will provide clues as to what CIS is doing these files, also check the quarantine to see if anything is getting quarantined.

None of the software is cracked. (it’s even deleting windows updates)
There are no trainers.
Nothing is in quarantine.
Of course there is third party software on the simulator they are the addons I was talking about. But I’m getting no virus warnings and It’s not like one or two files are getting deleted… it’s entire installation folders. EZCA for example, gets deleted every 24 hours on reboot. the deleted program folders are still listed in Program Manager as being installed but the installation folder is gone.

Where would I find the defense+ log?


Its hard to believe that CIS is deleting files and folders without detecting malware which would be in the quarantine list. To open CIS logs, from the main interface click tasks then click view logs, from the log window there is a drop down list at the top-left side labeled show in which you can select to view the antivirus, defense+, firewall, viruscope, and other logs, also make sure you right click in the log window and chose entire period to show events from all time.

I have uninstalled… re-downloaded… and reinstalled. In the process I found that the installer file has changed since 7/23/2015 when I downloaded and installed the first time.

of 7/23 the file was cispremium_installer_5962_fe.exe and today it is just cispremium_installer.exe

I’ll start installing my software again now that I have reinstalled with the apparently more recent installer and see if the problem persists.


Turns out it was not CIS at all… It was comodo programs manager. I did not realize that after an uninstallation the computer must be restarted at which time CPM re-deletes (in case any files or folders were locked) all the files and folders known to be a part of a program that you uninstalled. As such Any program I uninstalled and reinstalled (making CPM installers and testing them) was subsequently being deleted…

CPM could really use a restart popup to avoid the problem.

At any rate things are looking good here now and so far I’m quite happy with the performance of CIS.