CIS keeps asking permission for the same applications!

I run Windows Vista x64 SP1(SP2 same problem) I have UAC Disabled. CIS version 3.5.57173.439

I’ve seen a similar post here with the same problem. I decided to post my own thue I use Vista and he used Windows XP SP3

Comodo Firewall keeps asking permissions for the same applications Vuze fka Azureus and mIRC, other firewalls don’t do that.

It’s like this. I have Vuze installed on a encrypted container Every boot I mount this container and start Vuze along with mIRC. And everytime Comodo Firewall ask for permission.

  1. I have tried everything. Been allowing every request for a week, Comodo never learn

  2. I have tried to set Comodo in “training mode” but as soon I change that and reboot, same problem start all over again.

  3. I tried to set applications to “trusted application” still don’t work. Comodo firewall keeps asking like it’s mocking me! (V) (J) (M)

See picture, these rules keeps getting added

[attachment deleted by admin]

Seriously, it would be nice if one of the devs could at least leave a comment on this issue.
It seems to occur with TrueCrypt containers/partitions when those aren’t mounted before the Comodo CIS starts, so as I’ve written in my post regarding this problem ( it most likely happens because of a verification process of the program paths.