CIS issues wasting hours of my time...

I recently upgraded my PC hardware and so went with Windows 7 ult. 64bit, and have had two issues in the last couple days that caused me some time & grief.

First I tried to install Pelles C and the setup for it kept telling me it couldn’t write the file when it was trying to install. I tried various versions, 64bit and 32bit… finally I rebooted and tried again - this time Comodo popped up asking if I trusted the program (which it had not done on previous install attempts) and I answered Yes, after which it all installed just fine.

Then today I installed Haskell, and it seemed to go ok… but when I ran the interactive shell “GHCi” - it opened fine, but Comodo said it sandboxed and I clicked to not do so in the future. However, I was unable to type into the GHCi window. Even closing it and running it again (a few times) and still could not type into the window. (though the sandbox prompt didn’t come up again after the first time, which is as I would expect)

I finally had a hunch, and tried disabling Comodo Sandbox, Defense+, and Antivirus, and opened GHCi again - this time I had no trouble typing into the window and doing interactive Haskell stuff as one would normally be able to do. Note that as I mentioned, after the first time when I’d clicked to “not sandbox it again” I received no more messages from Comodo when running GHCi again, I simply could not type in the GHCi window.

Even now when I turned the Sandbox, Defense+ and Antivirus back on and opened the GHCi window, I can’t type into it, and receive no messages whatsoever from Comodo.

Every year or two when I upgrade or whatever, I try the Comodo utils but have inevitably run into issues that make me uninstall and go back to something else. I really want Comodo to work for me, as I like your philosophy, but things like this just make it more trouble than it’s worth.

Happy to hear suggestions, thoughts, etc… and I do appreciate that y’all let us use these for free, I just which I could use them without such breaking (for me) behaviour.

Regardless, thanks for letting me use your software, and of course thank you for your time.


This FAQ should help here.

Follow the links in the post re dealing with resistant items if moving the file from unrecognised files into trusted files does not work

Best wishes


Also, if you report the program to have it whitelisted here then you should not have trouble in the future.