CIS is not installed on Windows 7

I’ve downloaded CIS 4.0.138377.779 and tried to install it on Windows 7 Ultimate but the installer displays an error. See the screenshot.

Are you running the executable in compatibility mode for Win 2k or as Limited User?

Does the same thing happen with COMODO Internet Security 4.0.135239.742?

Unfortunately 4.0.135239.742 has the same problem. I do not use any compatibility mode and work as administrator (UAC is turned off).

Are you on x64 or x86? Are you sure you use the right installer?

I use 32-bit OS and CIS installer for 32-bit OS (cis_setup_x86.msi).

No rights? Can you run the installer package as the “Administrator” administrator user, please? Check this out, maybe a GPO problem. Strange one…

What do you mean with GPO? Group Policy O-something?

I logged in as “Administrator” user and tried to install CIS. I still have the same error.

I’ve downloaded Orca and tried to debug the CIS installation script. So the variable “VersionNT” in this script returns “700” value instead of “601” for my system.

Are you using some type of adapted version of Windows 7?

I’m using OEM English Windows 7 Ultimate x86. What is “adapted” version?

With adapted I meant pirated version…:wink: Yours sounds like a legit Windows version.:slight_smile:

I am puzzled by this. Since you are deconstructing the installer can you tell me where it looks to determine the Windows version?

  1. Open cis_setup_x86.msi in Orca.
  2. Select “LaunchCondition”
  3. Find “VersionNT = 501 OR VersionNT = 502 OR VersionNT = 600 OR VersionNT = 601” field
  4. Change description of this field to: “Windows version is [VersionNT]”
  5. Save as “somename.msi”
  6. Close Orca and run somename.msi


Try typing winver in the command prompt and see what it tells. Can you post a screenshot of it?

Can you try looking up the version number in the registry as described here: .

What does it report?

CurrentBuildNumber: 7600
CurrentVersion: 6.1
EditionID: Ultimate
ProductName: Windows 7 Ultimate

BTW, Windows Installer thinks that I have Windows 7.0… Very strange problem.

With Windows Installer you mean msiexec.exe? It sounds like it does so for all other Windows Installer based installers as well.