CIS is crashing legitimate apps

This issue goes way back to Windows 8 and very first beta of CIS 6. Sadly, it still exists.
In short, completely safe apps, like MPC HC, Photo Gallery, nVidia CP. Crashes happened in two files so far: ntdll.dll and USER32.dll, with error codes 0xc0000005 and 0xc000041d. CIS’s logs shows nothing and Windows logs only shows they crashed and that’s it. Changing auto-sandbox settings and restarting system gave me mixed result. Reinstalling OS helped only for a few minutes, after some restarts it came back.
MPC HC crashes occurs only when CIS is fully loaded. When I started playing video at the beginning of start-up, it played just fine. But the moment CIS kicked in, it crashed and stoped working, until I uninstalled CIS.

Does it happen for many other apps as well? Essentially, I’m asking whether there are some safe apps which you use often but are not affected by this.

Also, from what I understand this also happens with the default settings. Is that correct?


Firefox, Trillian, RTSS, Steam, ASUS AI Suite III, Dropbox, Skype, those are all unaffected. At least I didn’t notice anything.

Yes, with both default and custom settings.

Are there any unknown files at all?

Also, does it help if you add those files to the Behavioral Blocker exclusions?


Didn’t try that. I only tried to add them manually into whitelist, with no avail.

There is one weird thing though. Not sure if this is by design, but full virtualization is sandboxing three schvost.exe processes.

Why do you want to sandbox those programs?

I don’t. It’s doing itself.

What is your Behavioral Blocker set to? Also, please Reset the sandbox and see if these processes are sandboxed again.


OK, I know what are you going to say, but the fact is this is the EXACT behavior as in v6. Why are those sandboxed is beyond my comprehension.

Anyway, reseting Sandbox did the trick and so long apps are working fine. So, they might accidentally fixed it in v7. That’s fine by me. :slight_smile:

If bug won’t return, we can consider this as fixed.

[attachment deleted by admin]

Are those three files sandboxed, even under default conditions, or does the problem occur regardless of whether those are sandboxed or not?

They are sandboxed only with full virtualization. Speaking of which, they were sandboxed again after restart and few minutes.

P.S.: I’m going to fill several bugs to beta section. They are the same, so dunno how you want to categorize them.

Submit only one bug per topic. Also, to avoid confusion, in your bug report for this specify that it occurs with default configuration. Thus, the sandboxing of these three apps appears to be unrelated to the crashing apps.

Crashing stopped. The rest remained. And I’m not even sure why it stopped in v6. It might come back. Or not.

I have no idea why/how/who.

OK, I’m giving up for now.