CIS Installer extracts files to 100% then abruptly stops on a win XP SP3 PC

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:The issue can be reproduced anytime I wish by simply installing or trying to install CIS both in normal mode AND in safe mode?
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:uninstalled all security programs from pc?
    2:as posted by Chiron ran Revo uninstaller ran the Two Cis uninstallers?
    3:tried to install cis and received an abrupt ending after file extraction phase no new window appears?
  • If not obvious, what U expected to happen:
    ?expected cis to continue in the installation process!!!
  • If a software compatibility problem have U tried the conflict FAQ?:
    ?tried it already
  • Any software except CIS/OS involved? If so - name, & exact version:
    ?no other security software involved all was uninstalled to make room for Cis install
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    ?cis for some reason cannot open registry keys AND even Microsoft Fix it program as suggested by Chiron
    in Step B returns with an error saying an error has occurred and please try again later
    [/ol]

B. YOUR SETUP
[ol]- Exact CIS version & configuration:
?CIS 7, 0, 317799, 4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    ?no modules installed because cis never gets to this point
  • Have U made any other changes to the default config? (egs here.):
    ?none made
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    ?no first install from scratch
    [li]if so, have U tried a a clean reinstall - if not please do?:
    ?have tried used clean installs only
    [/li]- Have U imported a config from a previous version of CIS:
    ?no
    [li]if so, have U tried a standard config - if not please do:
    ?yes standard
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    ?win XP SP3 32 bit run in administrator mode full privileges pc desktop pc dex
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=? b=?none have deleted all to install cis
    [/ol]

Please also not that upon trying to install the MS Fix it installer to resolve problems due to installation errors with programs as suggested in Step B even the MS automated Fix it utility returned an error saying to try again later…Also please note that any other type of program even security programs get past the initial stage and do indeed show a second install window cis just extracts files and then ends there.

[attachment deleted by admin]

My feeling is that this is likely a problem with your system, and not necessarily a bug with CIS. The reason I assume that is because the Microsoft Fix-It tool fails as well.

However, I am not sure what type of advice to give at this time. I have asked the other Mods for advice. I will respond back when they have offered assistance.

Also, I just want to make sure of another thing. Have you tried downloading a new version of the installer? Sometimes an installer can become corrupted, and thus not install correctly. Does a new installer show the same behavior?

Thanks.

Did you run the Windows Installer Cleanup Tool? That is not clear from your description. Also could you specify which Fixit you have run trying to fix the problem?

To see if the problem is one with Windows Installer in general try installing Skype for Desktop: Download Skype for mobile & desktop | Skype . This also uses Windows Installer. I want to see if the problem is also with this or not.

Hi Chiron and EricJH

Thank you BOTH and for those who would also give their hand thanks to you all as well for your time and help taken out of your busy schedules

Well as requested the Fix It program was taken from the link in point B of Chiron’s post and to be precise the version is MicrosoftFixit.ProgramInstallUninstall.RNP.343231911989358.3.2.Run it is in Italian on the MS site as the operating system is in Italian but this shouldn’t matter anyway. This would be the Windows cleanup installer tool.

I also did try installing Skype for desktop as suggested and this version is 6.14.0.104

No problems during install except that the language choice in the drop down menu was not there it only gave me a blank rectangle and installed in Italian

The installation took about 15 minutes and skype did show up and is working normally

Wonder what could be holding CIS up?

Thanks again and hope to hear from you when possible.

I had not noticed this change. The Fixit tool does indeed what the old Windows Installer Cleanup Tool did. Apparently it did not find anything or it did not help.

I also did try installing Skype for desktop as suggested and this version is 6.14.0.104

No problems during install except that the language choice in the drop down menu was not there it only gave me a blank rectangle and installed in Italian

The installation took about 15 minutes and skype did show up and is working normally

Wonder what could be holding CIS up?

Thanks again and hope to hear from you when possible.

The problem is not with Windows installer.

When installing CIS will extract the installer in "%systemdrive%\Documents and Settings\All Users\Application Data\Comodo Downloader. try emptying that folder.

Also run checkdisk to be on the safe side of things: CHKDSK - How to run in Windows XP - Windows Made Easy - XP .

Thanks EricJH for this info… I went to examine the folder you mentioned and on my machine it is saying Comodo and then as subfolders it has CISDumps and Installer don’t know whether the top folder should have read Comodo Downloader or not.

In my case I emptied eliminated the CisDumps folder and the Installer folder and thereby left an empty Comodo folder with NO subdirectories

After this I tried to install again Cis version 7.0.55655.4142 and the same abrupt ending after file extraction appeared…next I went to check on the Comodo folder and inside it there were once more the CisDump and the Installer folders…

I have not yet tried the chkdsk procedure but I will do so and then report back to you once more…In the meantime if these folders can rpovide any clues as to what is happening would you like for me to send the files in them to the forum?

Thanks once again for all your help and I will get back to you again after having run chkdsk and after having tried another install of CIS after chkdsk.

Hello back again…

I have tried the Comodo folder subdirectory deletion and also a complete deletion of Comodo folder and afterwards the run of chkdsk and then a new install of CIS

Unfortunately for me the results are still the same as before…just wished to let you know about it…

Other ideas/tips/insight will always be welcome…txs for your help

Hi ROBDOCFP,
Before re-running the CIS installer, check the following location and delete any files related to CIS.
C:\Documents and Settings\Username\Local Settings\Temp

Note: You will need to temporarily set the folder options to ‘Show hidden files and folders’ to see this location.
To display hidden files and folders-Microsoft

Kind regards.

Hi captainsticks and all those who are viewing this thread

Here is an update…I have done as you suggested and have deleted the Comodo folder and also have deleted comodo related files in the Temp folder under Local settings…I then proceeded to install CIS and the end result is that file extraction does take place but then the install stops from this point on…Unfortunately no progress as of yet and back to the beginning.

Txs for the suggestion…I am sure that this info and the info of others will surely bring to the solution of my problem.

Thanks Capt. and all!!

Kind regards from ROBDOCFP

Considering this issue arises at the point of extraction or soon after, I have been wondering if it might be worth trying the 32-bit only installer.
This can be downloaded from the external source in the link below.
Comodo Internet Security 7.0.317799 (32-bit)-Filehorse

ROBDOCFP, was using the 32 bit installer able to solve this issue?

Thank you captainsticks and Chiron for your input and suggestions. I DO apologize for not having gotten back sooner than usual …just couldn’t get to the testing phase of your ideas on this matter. Today I have done all suggested and specifically

  1. Downloaded the x86 version from Filehorse of approx 92 MB
  2. Deleted completely the Comodo folder
  3. Deleted instances of CIS in the system Temp folder
  4. Booted the computer into Safe Mode and proceeded to install the 32 bit only version of CIS as Administrator
  5. Extraction part is faster than th2 32/64 bit installer but AGAIN then it abruptly stops there and goes no further
  6. Repeated the install procedure from steps 2 to 3 but this time logged on as user J who in any case has full administrator privileges being an administrator account as well
  7. Ran Task Manager to see what was happening during File Extraction of the 32 bit version and I observed the following:

In the programs tab CIS appears as in execution running with the percentage of file extraction shown on screen

In the process tab there are the usual Windows processes such as explorer svchost csrss etc…no Comodo processes ever seen here and maybe not ever meant to be seen in the first place…

After file extraction reaches 100% the CIS extraction message in the Program Tab disappears for good…no other messages appear and no error messages appear either…

Memory usage during the extraction phase is normal nothing shoots to 100% and CPU usage during this phase too is around 8% quite normal…

Unfortunately this is all I can say and see for the time being wish I could have come back with something better for you who have been helping me from day 1…but for sure something sooner or later positive will occur.

Thanks again and Best wishes to you all.

:slight_smile:

I really don’t think that this is a bug, but rather something interfering with the installation process. I’m not sure what, but that’s my feeling. I will therefore move this to the HELP section of the forum, where others will hopefully be able to provide helpful advice.

I did have one thought though. When you removed the other security software did you run the dedicated removal tools for them? If not it’s worth trying that and seeing if it helps.

Thanks.

Hi Chiron,

Thanks for the input. Well I removed the security software first such as Avast with its own uninstaller aswclear then mbam with its own mbam clean utility and the super anti spyware with revo uninstaller and finally 360 internet security with revo as I had previously looked for custom uninstallers for Super antispyware and 360 Internet Security but found non on their sites so therefore I used Revo…Also I DID use the ESET utility to remove security programs but it found nothing to remove when used…so I thought I was good to go at this point…turns out I was NOT.

Thanks for your and everyone else’s time and help and for the post info about it being moved to the Help section of the Forum

Just a quick question according to you what do you think it could be AND should I just go the drastic way Not that I want to obviously! and repair and if not successful then reinstall Windows?

Kind regards,
ROBDOCFP

I’m sorry, but I don’t really have any other ideas for what you can do to try and solve this issue. It is very strange. Hopefully someone with more experience with installation issues than me will be able to suggest a solution.

If nobody has any ideas within 4 days or so please send me a PM.

Thanks.

Hi ROBDOCFP,
I noticed that you are considering re-installing the operating system.
Considering this, I suggest you may won’t to try resetting registry and file permissions in case the permissions have become corrupt in some way before taking the step to re-install the operating system.
My suggestion is to use a command script tool, with no guarantee that it will help.
Caution-This tool does modify the system and registry, so it is to be used at your own risk!

  1. Download the ‘reset.zip’ found part way down to page in the external link below.
  2. Right click the zip folder and ‘extract all’ to a known location.
  3. Double click the run the tool.
    Reset the Registry and the File Permissions in Windows XP-winhelponline

Apart from the above possibility, I am not to sure what else to suggest.

captainstick’s suggestion gave me another idea. If following his advice does not work, it may be worth looking at the advice given in my article here. Let me know how it goes or if you have any questions.

Thanks.

Hi ROBDOCFP,

I’ve had a similar problem,
At the time I used CCleaner to clean temporary files and run Registry Cleaner.
I used Advanced SystemCare for a deep check and correct possible errors.
I downloaded the installer with official Comodo link and checked SHA1 hash to see if the file is not corrupted.
Done it all installed normally and had no more problems.

CCleaner Professional | Try the world’s most trusted PC cleaner, free! (CCleaner)
http://www.iobit.com/ (Advanced SystemCare)

I hope some of this information might help, as already mentioned by friends here. :slight_smile:

Thanks Chiron for your ideas and also to jhkmaster and captainsticks also for your PM offfer if all else fails hope not!!! will look at everything your article the tweaking.com website and ccleaner and iobit in a couple of days just to keep you up to date then I will post back and do everything step by step to see what gets to the problem will let you know so this may help others too…just give me a few days to test can’t do it right away now but for sure you will receive info from me…and for now you receive my sincere thanks!!

best from me to you all!!

Its a scientific fact that when this happen, something is ■■■■■■■ up. Why something is ■■■■■■■ up is a much easier prollem to solve than what actually is ■■■■■■■ up.

Instead of messing around with what and why things are ■■■■■■■ up, try extracting the contents of the installer manually.

Right click the installer and select the archive tool option of your choice, e.g., WinRAR, 7zip, etc…

The installer will open with the archive app of your choice. Then extract the contents of the installer using folder names to a temp installer folder, e.g., F:\Installs\CIS_install

Then run the setup from there, e.g.,

cis_6_3_302093.exe\cis\download\installs\xml_binaries\cis[i]cis_setup_x86.msi[/i]

OR:

cis_7_0_55655_4142.exe\cis\download\installs\xml_binaries\cis[i]cis_setup_x86.msi[/i] (or cis_setup_x64.msi as appropriate)

IF you can NOT extract the installer contents manually due to extraction error, then you have a memory prollem, i.e., physical damage or misconfigured WRT timings, freq, or dual-channel mismatch incompatibility. A quick test of the entire memory system can be performed by running Prime95; worker threads for each core should execute w/out abortion. If one or more worker threads abort there is a memory prollem somewhere in your system, e.g., CPU, CPU cache, motherboard, motherboard cache, memory controller, SDRAM. The latter can be best dx’d w/ memory tester, e.g., MemTest86 The latter prollem can be due to physical DIMM damage, or merely misconfigured / mismatched DIMM (especially when DIMM are installed in dual-channel configuration).