CIS installation problem

I just tried to download CIS from the Comodo website,free version 64bit for windows pro 64, but when I try to run the set up file I get the following message: the set up program is not a valid win32 application. What does it mean?

Maybe a corrupted download.

The installer is a digitally signad app you can check its properties and validate the signature to check if the installer is corrupted.

How to Verify PatchWork’s Digital Signature

All I am trying to do is downloading the CIS from the Comodo website, I don’t think I am supposed to verify the signature, it is a non sense. I am just trying to understand why it won’t do it, that’s it. I already did it last week for my windows xp 32, and it worked fine, but it won’t let me for my windows pro 64.

Then please download it again. If still doesn’t work and you are not willing to verify if it is corrupted there is not much left to do.

EDIT: no need to download it again. I did that and I confirmed that the file is corrupted and has a file size of ~9.7 Mb whereas the 64bit installer size is stated 39.9 MB (41,904,392 bytes)

Ok, thanks a lot gibran, is there a way to let the comodo people know the file is corrupted? I am surprised no one is having the same problem as me, maybe the 64 bit OS are not that common…what do you suggest?

You could download it from

I already sent a PM to inform Comodo about the corrupt installer.

Hi Gibran, again thank you, the link you posted works, I appreciate the time you spent to help me out, you have a good evening (:WAV)


You’re welcome :slight_smile: