CIS Help

Hi, I recently ran the Diagnostics feature of CIS and it reported to have problems which it cannot fix. I asked it to generate a .txt file. I’ve attached it. Is there anyone who can help me fix this? Thank you.

*I reinstalled CIS but it still has this problem.

[attachment deleted by admin]

Hello Kartgar,

Looks like it’s missing registry key’s for guard32, did you run any other security software next to the install of CIS, it looks like something blocked the creation of the registry key’s that need to start this service.

I suggest to uninstall, temporarily disable the other software reboot and try to install again.

Hello!

Before re-installing CIS, you can try adding the registry key and see if it helps. Download the attached file, and run it. It’s a simple registry file that will add the missing key.

[attachment deleted by admin]

Don’t forget to reboot after the import of the registry key :wink:

Thanks for the quick reply.

[at]Ronny: I tried reinstalling it but still same problem. >.<

[at]Ragwing: It says that it cannot install the reg file.

I’ve also attached the .txt file after re installation.

[attachment deleted by admin]

Hello Knox,

It looks like your running a “normal” account, registry import needs to be done while being logged in administrator, can you please try again with an Admin account ?

Did you install with this same limited account ?

My User Account is set to Computer Admin when I tried installing from the start.

Well then there is something wrong with your system, do you have Defense+ active during import ?
maybe you blocked something ?

Can you try with D+ set to disabled and or Training mode ?

Nope, firewall, defense + and my AV are all disabled. :-\

Try the following:

  1. Open the start menu, and click Run (alternatively: Windows-key + R)
  2. Write regedit
  3. The Registry Editor will now open. Click the keys in the following order: HKEY_LOCAL_MACHINE → SOFTWARE → Microsoft → Windows NT → CurrentVersion → Windows
  4. Right-click Windows and choose Permissions. From here, choose Administrator and make sure that you have full access to this key from an administrator account. If not, tick the box to allow full access.
  5. Try running the registry fix again.

If you have some experience with the Registry Editor, you can add a new string value to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows named AppInit_DLLs (if it doesn’t exist) and add the data C:\WINDOWS\system32\guard32.dll to it.

If the above doesn’t work, try booting in Safe Mode (hold/tap F8 while booting), and run the registry fix.

If I’m not mistaken, you are referring to the file you uploaded as “registry fix”, correct? Cuz there’s also a program called registry fix. Anyway, thanks, I’ll try this out and post the results. :slight_smile:

Yes, it’s the file I uploaded. And please return here with your results as soon as possible. :slight_smile:

This is a very late reply but I managed to fix the problem. Thanks for helping me out! :slight_smile: