CIS Freezes my PC when run with Open MPI and MinGW

A. THE BUG/ISSUE:CIS freezes my machine

  1. What you did:
    a. Download and install MinGW
    b. Download and extract OpenMpi Open MPI: Version 1.4
    c. Download ans Start CMake and Configure the source
    d. Open a MinGW shell and swith to the OpenMpi source
    e. type “./configure”
    f. System will hang/freeze eventually (when Defence+ is enabled and not in training mode)
  2. What actually happened or you actually saw:
    freeze
  3. What you expected to happen or see:
    no freeze :slight_smile: → Defence+ Dialog
  4. How you tried to fix it & what happened:
    my system is configured to make it crash (bsod) on the “Strg right+double scroll lock” so i was able to get a minidump (http://dl.dropbox.com/u/23520882/ComodoFreezesPc-Dump.zip)
    If you want a minidump via another method just ask for it (i only know came up with this one method)
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware)
    CIS 5.10.228257.2253, Antivirus DB: 12234
    MinGW current version (i don’t think is should matter though)
    openmpi 1.4 source

:

  1. Whether you can make the problem happen again, and if so precise steps to make it happen: see 1
  2. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):
    ? can’t on freeze!
  2. Screenshots illustrating the bug:FREEZE
  3. Screenshots of related CIS event logs:Could not find a entry related to the freeze
  4. A CIS config report or file:http://dl.dropbox.com/u/23520882/ComodoConfig05-05-2012.zip
  5. Crash or freeze dump file:http://dl.dropbox.com/u/23520882/ComodoFreezesPc-Dump.zip
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version:

C. YOUR SETUP:

  1. CIS version, AV database version & configuration:http://dl.dropbox.com/u/23520882/ComodoConfig05-05-2012.zip
  2. a) Have you updated (without uninstall) from a previous version of CIS:NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):Sandbox is disabled
  5. Defense+, Sandbox, Firewall & AV security levels:Paranoid,Off,Own Ruleset, Intelligent
  6. OS version, service pack, number of bits, UAC setting, & account type:Windows 7 Service Pack 1, 64bit, UAC ON, Administrator
  7. Other security and utility software currently installed:None
  8. Other security software previously installed at any time since Windows was last installed:MSSE
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:

Thank you very much for your report in standard format, with all information supplied. (The dump file should list all active processes, so this is not required in this case). The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Just to clarify, I assume that by ‘intelligent’ you mean ‘stateful’

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Jeah I do, in the german translation its called “intelligent”

Is this resolved or worked on?

Im asking because I think I get very similar errors when using other programs which are spawning lots of child processes (like cygwin or git), my pc is always freezing in those scenarios, my current workaround is that I disable Antivir and Defence+ (my guess is that Antivir is causing this) in those scenarios.

This is the Fullscreen minidump (Most likely from using git), it is created by the method used above
I did “git svn clone -s http://cpachecker.googlecode.com/svn/ .” (svn url changed)
https://dl.dropbox.com/u/23520882/Fullfreeze%20120817.zip

Maybe you should change the title or merge it with exisiting Threads if there are any?

reddragon