CIS Firewall is not working under Windows 8

I switched to Windows 8 yesterday and installed CIS 5.12 as usual.
My problem is that I don’t receive any notifications od alerts regarding any applications trying to access the internet. Absolutely every traffic is allowed even under custom policy behavior. No restrictions at all.

I checked the Windows Firewall and noticed that the Windows FW was still running and I disabeld it hoping CIS will “take over” now, but nothing happend.

I thought maybe all applications are considered “Metro Apps” and deleted the Applications Rule for them - still no effect. I deleted every Global Rule and Application Rule just to see If I get a pop-up regarding any application trying to access the internet. E.g. Steam, Dayz Commander and certain games all got through like there is no FW at all.

Is the FW really broken or am I doing using it wrong?

Are you using Proactive security mode?

No, I don’t think so. I installed both FW and AV and I’m using the default configuration. I only switched the FW to Custom Policy and the alert frequency level to medium.

Hi Shnix,

You don’t have by any chance “Do not show popup alerts” > “Allow Requests” enabled under Firewall Behavior Settings > General Settings?

Indeed I had this enabled :embarassed:
Why is this enabled from the start? And why is this able to render the FW useless if any request is allowed?

I’ll try harder in the future not being too stupid for this app. Thank you Boris

On CIS install, the installer shows it selected by default; the user who doesn’t want it have to deselect it in the options of the installer.
This feature is there to make life easier for users who are not FW savvy.