CIS Firewall in v8.20.4508 not running in Windows 10 build 10061 & 10074

Problem: Windows build upgrade kills firewall component of CIS
CIS version: v8.20.4508
O/S: Windows 10 Insider Build 10074 X64
Other security software: None
Steps to duplicate: Upgrade from Windows 10 Build 10049 to Build 10061
and also then to build 10074.
Worked previously: Windows 10 Preview Build 10049 X64
Steps taken: Uninstall, reboot, clean registry, reinstall, reboot, No changes

I had read on the MS web page, some programs may stop working with the upgrade. They didn’t explain why, what, or how.
Could this be an issue with the current Win10 build? Has it been reported to them also? (just asking)

Hi

It did same for me as well. But after the reinstall it worked again. I have only free firewall active. Actually, I don’t know what is not working, firewall simply reports it is not working properly. When I click FIXIT-button, it runs a while and then says it went wrong and offers to create a report. Report has long list of events that say

Too long process chain: pid=4656 m_dwParentPid == 4724

I have attached the report (in zip format, which seems to have both event log format and xml format of it.

This is a newest version (8.2.0.4508) of the free firewall, installed just after upgrading to 10061.

Is there some other info I could get?

System is oldish AMD Phenom II 1070T with 8 GB RAM, 256 GB SSD (where W10 X64 resides), 1500GB and 1650GB SATA HDD’s, AMD 7790 1 GB GPU, Avast 2015 free antivirus software and nothing much else (it is in this configuration just a test system for W10).

Regards

kp

[attachment deleted by admin]

I have the same problem on several PCs (real and VMWare).
The Comodo Internet Security Firewall Driver is no longer loaded even after a reboot.
Only solution until now is to do a complete de-installation and re-install Comodo again.
This has to be done at every new Win 10 TP :frowning:

Hi Guys,

We have tested CIS and Windows10 9926 during the implementation. Anyway I will check this with QA s.

For your kind information

Best Regards
Buket

Hi again

Just upgraded Windows 10 to 10122 and same thing happened: Firewall was started but told me network protection is not there. But as I upgraded other app, it asked normal questions about allowing app to start another app. And that went just fine.

I have enclosed two diagnostics reports, first one taken while Windows Update loaded the upgrade (and everything was working normally still) and second one after the upgrade had gone through (and firewall felt sick). The second one is full of those “Too long process chain” remarks, but the first one has only two items:

   Failed myRegistrar->Register 0x8004100e

   Service started/resumed

I’m sure it will be okay again after reinstall.

Any info from QA people?

And I have posted this item to Windows Insider forum (in Finnish) at hte same time I did here but so far no comments from there.

Regards

kp

[attachment deleted by admin]

Had same issue.
Fixed by uninstalling Comodo Firewall, restart Windows, and reinstalling.
Attached report files if it is of any help.

[attachment deleted by admin]

Hi again

Similar behaviour with Win 10 TP 10130. Works again after reinstall.

Hi again

Same behaviour on Win 10 TP 162. Worked again after reinstall.

Then on TP 240 Comodo disappeared. That is, it was still installed but not started after boot. When I triedmto start it manually, there was no response. Then I uninstalled it and tried to install it, I got a message telling me this program was not allowed to be installed on this Windows version. Installer was 8.2.0.4591. After searching these forums, I found a workaround by Sanya IV Litvyak

https://forums.comodo.com/install-setup-configuration-help-cis/windows-10-tp-no-longer-allows-cis-82-to-be-installed-t112043.0.html

which gave me working firewall (and AV and …). I stopped those extra services, so it appears that everything works again.

I have also heard from Windows Insider Forum that F-Prot AV Suite also has had problems surviving these upgrades. So apparently MS has changed things securitywise a bit.

But it appears that Comodo is working on these problems, so we’ll wait and see ??? .

Hi Guys,

Thank you very much for the feedbacks.

We are working on it .

For your kind attention please.

Best Regards
Buket

Same problem here. I had to clean install also for it to work.

One more for me but in Windows 7 SP1 x64. CIS 8.2.0.4703.
Similar messages to what’s posted above.

The description for Event ID ( 0 ) in Source ( cmdAgent ) could not be found.
Either the component that raises this event is not installed on the computer or the installation is corrupted.You can install or repair the component or try to change Description Server.

The following information was included with the event (insertion strings):
Failed myRegistrar->Register 0x8004100e

The service’s stop/start options are inactive and the widget shows zero connections and traffic.

It must have started during the last day or two.
The only thing of interest I did to the system is to disable the builtin wireless card (it’s a laptop) and add a USB one (which I use).
I kept the same IP since I’ll be using only one of them at a time.

Does Comodo tie to the net cards in the computer during installation and throws a fit if a new one is added, therefore the need for its reinstall?

I assume it may find the new adapter its self and will install the Comodo Internet Security Firewall driver for the new adapter. Can you check the Properties of the new network adapter and see if the Comodo Internet Security Firewall driver is there?

Can you let CIS run Diagnostics and see what it reports? Can you attach the diagnostics report to your next post in case it finds an error? Can you check in Task Manager (showing processes of all users) if cmdagent.exe is running?

Thanks for looking into it.

The firewall driver shows as enabled in the new adapter. I disabled/re-enabled it with no difference.

cmdagent shows as running and the service can’t be stopped or its task killed.

Diagnostics didn’t find any errors but I attached the report just in case.

[attachment deleted by admin]

CIS is running properly. :slight_smile:

What the error message is about I cannot tell. I assume it is from Event Viewer. From what subsection of Event Viewer is it?

Good to know it’s running properly even if it doesn’t :slight_smile:

Initially I saw the message using Event Log Explorer 4.5 (free personal license).
In the Windows Event Viewer it’s under “Applications and Services Logs”->“COMODO Internet Security”

I attach a screen capture.
The 3rd entry is for the service restart/resume and the rest are all the same as shown.

[attachment deleted by admin]

Can you see what is under Comodo Internet Security Trace? Can you post a screenshot? Do you run as Limited User under Windows or as admin?

I run the system as admin with UAC off.
Both COMODO security CEF and Trace logs are empty.

In the Windows Application events log, cmdagent shows as having started successfully.

I could reinstall Comodo and would probably fix itself, but I’d never know what caused this and where’s the fun in that? :slight_smile:

It has me puzzled. It might be a bug with logging its own events.

Sorry for the delay responding.

I just tried something and the problem seems much worse than a logging error.
cmdagent runs but does nothing.

I use the ‘Web Browser’ ruleset for Chrome and the rest.
I added a block & log rule at the top of that ruleset. Block tct/udp out for any address/port.

No difference. I can still surf to where I want and the widget shows zeros for everything.
The firewall events log shows nothing but a few minutes before I tried this, it had asked for permission for some other program (not in the ruleset) and it logged my response.

It looks like it ignores my current rules and just traps new cases.
Weird eh?