CIS firewall doesn't work with HUAWEI USB data stick model K4510 [Issue Report]

The bug/issue

  1. What you did:

Tried to access internet through a 3G USB data stick (HUAWEI K4510)

  1. What actually happened or you actually saw:

I noticed that the CIS firewall does not function with Vodafone Mobile Broadband K4510 (Vodafone branded HUAWEI K4510). Even with the firewall set to “Block All”, all connections are allowed.

  1. What you expected to happen or see:

Connections should be filtered/block according to the defined rules

  1. How you tried to fix it & what happened:

I first tried to uninstall CIS and install it again. Same behavior.
I noticed that the CIS firewall driver is not installed for the Mobile Broadband connection so I then tried to manually install it:

a. go to Network Connections
b. rigth-click on the connection, choose properties
c. click Install, choose Service, choose inspect.inf from C:\Program Files\COMODO\COMODO Internet Security\

I do not get any errors but the driver is not being installed (fails silently). Please see the attached screenshot.

  1. If its an application compatibility problem have you tried the application fixes here?:

N/A

  1. Details & exact version of any application (execpt CIS) involved with download link:

N/A

  1. Whether you can make the problem happen again, and if so exact steps to make it happen:

every time.

  1. Any other information (eg your guess regarding the cause, with reasons):

not sure

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:

see attached vdf-network.png

  1. Screenshots of related CIS event logs and the Defense+ Active Processes List:

none

  1. A CIS config report or file.

none

  1. Crash or freeze dump file:

none

  1. Screenshot of More~About page. Can be used instead of typed product and AV database version.

CIS version 5.5.195786.1383

Your set-up

  1. CIS version, AV database version & configuration used:
  2. a) Have you updated (without uninstall) from CIS 3 or 4:

NO

b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  1. a) Have you imported a config from a previous version of CIS:

NO
b) if so, have U tried a standard config (without losing settings - if not please do)?:
4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):

maybe

  1. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =

sandbox off, firewall custom, d+ paranoid

  1. OS version, service pack, number of bits, UAC setting, & account type:

Win 7 SP1 x64, UAC disabled, admin

  1. Other security and utility software installed:

NONE

  1. Virtual machine used (Please do NOT use Virtual box):

N/A

[attachment deleted by admin]

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis