CIS Firewall blocks windows network sharing


At home I am using CIS v10.1.0.6476 with Windows 7 x64 on my main computer.
All works fine but the network sharings are blocked by the firewall somehow.

Firewall rules: all microsoft services are allowed, incoming and outgoing
Network zones: I added manually my network range to the “home” network zone ( -
general network setting: fixed IPs for router and computers (, same MS workgroup for all

Everytime I try to access a network folder from another computer it’s not accessible. But If I turn firewall off for 15 minutes (or completely turn the firewall off) and then access the network folder it works just fine.

Any idea what’s the probleme here?

Hi Stefanseiner,

Please provide your current config and Microsoft event logs.

Steps to import current configuration:
Export your current configuration by following this guide

Steps to collect Windows Event logs:

  1. Go to Windows Run (Windows Key + R key in keyboard).
  2. Type in eventvwr and press Enter key, it will launch Event Viewer window application.
  3. Select ‘Windows Logs’ → ‘Application’ in opened window.
  4. Right click on it ‘Save All Events As…’.
  5. Save as ‘Application’ events.
  6. Repeat steps 3-5 for ‘Security’, ‘Setup’, ‘System’ events.

Thanks in advance.

Kind Regards,

Can you show a screenshot of your Global Rules and Manage Networks?

I think this should not be for public access so I send you a Mail.
Thank you very much for looking on it.

I just added two rules. Rule “VNC” is for incoming access via RealVNC from my laptop over lokal network on ports 5800-5900, “Netzwerk” is my try to allow network sharings.

network zones - I don’t know why CIS created two “home” zones, I never changed my general network settings, it’s with fix IPs in the mentioned range since ever

I don’t know what’s about the entry with the IP, it’s made by CIS.
The entry with IP is this computer,
I just added the very last entry with the IP range of my private network.

Check for any blocked events in the firewall logs, also make sure you do not have any block rules for System and svchost.exe in application rules.

The entry Comodo made, i.e is a Network Mask, that tells the network stack how far its allowed to map network devices, the .0 in this case means only local network devices.

Make sure the ‘System’ rule is using your correct network zone.

Doublecheck. All Windows Services and Tasks are allowed.

I can’t see any zone at the system rule, but in- and outgoing traffic is allowed.

Your system rule should look something like this to allow LAN traffic.

Yeah - that’s it.
If mentioned above my CIS created two “Home” zones and at the system rule there was the wrong one.
Now after changing the zone number at the system rule the Lan traffic works

thank you so much :slight_smile: