CIS-firewall blocks all internet access even if CIS not running?

Here’s my problem:

I install CIS to get a look and feel for it and take it for a test run. Everything seems fine and dandy until I turn it off. I try to start Miranda (IM for msn, aim, etc) and it can’t connect anymore!?! If I turn on the firewall and then try to connect I can allow it and it connects just fine (I didn’t run Miranda during my first test run). After doing that I can connect with Miranda even while CIS isn’t running. This problem occurs with all programs trying to connect to the internet.

Is this just a hidden security feature of CIS running somewhere (not cmdagent.exe, I’ve tried doing the same thing with it turned off) or some oddity occurring just to me?

Also, I got a little tired of cmdagent.exe running all the time even when CIS wasn’t running so I disabled it from starting up with windows and instead made a script for it to start up when I start CIS and terminates it when I close CIS. Is there some functionality lost in this process? (besides it not running all the time)

thanks, rakhim

CmdAgent is the main body of CIS. CFP is just the user interface (GUI).
By disabling CmdAgent you are in effect removing the network security it offered you.
As for applications running after disabling CIS, once the firewall rules are in place, your apps will run fine all the time, even when no rules/protection is in place.

I got a little confused.

So what you’re saying is that after I’ve enabled everything I want to enable there’s no point in running either of the GUI or cmdagent since the rules will be enfoced anyhow? I think I’ve added all exceptions and such so the problem is somewhat solved for now but I’m kinda curious on how it’s done?

The problem is that I’d still like to have the option of turning my firewall “really” off in case I’d need to test if an application somehow fails to connect and rule out that it’s the firewall causing it.

Maybe disabling it via the GUI and then quit will solve that problem. (:LGH)

No, I didn’t say that. If the rules are not in place, you cannot connect to the Internet with the firewall on (that is your seciurity). Disabling CIS will allow everything access since there will be no protection in place.

So if my programs can’t access internet while CIS and cmdagent isn’t running something must be wrong? (this wasn’t a problem before installing CIS)

As in earlier post, if I disable the firewall via the advanced, firewall behavior settings - all programs can connect just fine both while CIS is running and while it is not. But when I drag it up to safe mode only programs already cleared can access internet both when CIS is running and when it’s not. Those programs not cleared for internet access can’t connect through for some reason even when CIS isn’t running.

To anyone who has a idea.

I downloaded COMODO and liked what I saw. As per the other user, I turned off my computer and it would not allow me to log on to internet.

I uninstalled it and reinstalled it twice to see if I could figure out the problem, but I am stumpted.

Anyone with an idea???