CIS Firewall and ICS

I can not manage to configure CIS Firewall to allow Internet Connection Sharing. I think this is CIS issue because standalone Comodo firewall doesn’t have this problem. The rules I use with both programs are the same, but with CIS ICS do not work.
OC: Windows Vista Ultimate SP1 x64
CIS: 3.5.53896.424
CFP: 3.025.378

did you try using the stealth port wizard to define a trusted network?

Yes I did, I also try all that I find in forum about the ICS, the thing is that ICS work perfectly with the stand alone Comodo Firewall.

I’m fairly new to CIS myself but i do know that the stealth port wizard is what we use to use. now this puzzles me so as well hmm. maybe one of the forum admins will step in here.

Does pings goes between gateway computer and the client one?
Can you open some site using IP address of the site instead of it’s URL?
Have you got any block entries in Firewall logs when client computer is trying to connect the Internet?

Pings between gateway and client are OK, I can use services between two computers - sharing is OK, I can connect vnc server.
I added global rule to allow DNS Requests at port 53, with no success, because one of my guesses was that Firewall blocks it.
I’ll try this again and report back.

Problem is solved. You will never guess - I have to uncheck “This computer is an internet connection gateway (i.e. an ICS Server)”, so I thing this issue may stay in Bugs session.
Before that I can ping and trace a site for example, this is very strange because when browser request connection the Firewall asks about DNS request from the IP on internal network, but when I allow it nothing happens. I also tried to open site using IP address of the site but with no success.

i just updated from v3 to 3.5 and i basically have the same problem - none of my other boxes at home can use my (until the update working) ICS
i am able to ping “outside” IPs but somehow DNS requests don’t go through - and opening websites via IP doesn’t work either
but unchecking “This computer is an internet connection gateway (i.e. an ICS Server)” didn’t change anything about it - pls help :confused:

that’s win xp pro x64 with sp2 and the firewall version is 3.5.54375.427

ICS started working after I unchecked “This computer is an internet connection gateway (i.e. an ICS Server)” and the firewall request policy for “Windows Operatin System”, before that there was no such application in “Application rules” and no request fot it. So allowing “Windows Operatin System” may slove the problem, if only we know what this name realy mean.

that doesn’t show up in my application rules (in network security policy)
still can’t get it to work - i hope an admin reads this soon
girlfriend is getting totally annoying because her intarwebses don’t work :S

It is located here:
Advanced->Network Security Policy->Add->Select->Running Processes

my guess is: that allows EVERYTHING running to access the internet and won’t ask for anything ever again - so you might aswell use no firewall at all :S

Yes I thing you are right, only for windows processes, but I’m not sure. Does anybody know what this name means?
I applied rules as outgoing only + the rules for internal network to this process, and the firewall works, I scanned the system with nmap and all ports are filtrated.

I have the same problem. ICS is working well with firewall off. BUt with firewall I can just ping website trough cmd.exe but I am not able to open any in firefox or explorer. I’ve added my second pc to trusted zone with stealth port wizard and no progress at all.

PC with ICS: vista x32 sp1
second pc: windows xp x32 sp3 and firewall off

You probably need to allow svchost.exe on server machine in/out UDP connections for the local network zone.

Have the same problem with ICS on CIS.

It doesn’t help!

fixed by downgrading to CF 3.0.25