CIS Firewall (7.0.317799.4142) cmdagent.exe not running after reboot.

Hi there I have CIS Firewall (7.0.317799.4142) installed and cmdagent.exe not running after reboot.
If I try starting it myself with processhacker I get “cmdagent.exe did not respond in a timely fashion” the service runs fine if I run comodo’s diagnostic tool and that reports no errors :-\

I have removed CIS and re-installed via the add/remove programs and the removal tool ( https://forums.comodo.com/install-setup-configuration-faq-cis/uninstaller-tool-for-comodo-products-inc-cis-v5-t71897.0.html )

OS: Windows Vista x64 (Yea, lol)
Other security software: none.
Here is the report file CIS generated: http://dpaste.com/066C9T1

Any ideas?

Hi and welcome Sys,
I am failing to find the product Version you have listed.
Please make certain that it is a genuine copy of the installer.
Release notes-Comodo
It may be worth trying the latest version, which is found in the link below.
COMODO Internet Security 7.0.317799.4142 Released!

Kind regards.

Thank you, I rechecked the file version via the “about” thing in CIS ui and it’s “7.0.317799.4142” the version on the files it’s self isn’t right it says “7.0.53315.4132” also the files are signed by comodo so it’s genuine.
I even checked the loaded modules (DLLs) to make sure it’s not a DLL injection or something.

It’s been like this for ages, I un-installed CIS for awhile, Fully removed every trace of it reinstalled and it still does it.
I tried other products (comodo and others), they all work.

On a side note, older versions like 5.x of comodo firewall don’t do this I checked before.