CIS Dose not save a System Restore point.

A. THE BUG/ISSUE:

  1. What you did:Installed software
  2. What actually happened or you actually saw:No System Restore created even with the option ticked in the popup window that shows bottom right corner of monitor.
  3. What you expected to happen or see:Create a System Restore point.
  4. How you tried to fix it & what happened:Contacted CIS Help forum told to submit a bug report.
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: N/A
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):Windows 7 Home Premium + service pack 1 and all updates as of 31/01/2012
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:Yes Install a program that will cause CIS to bring up pop up window bottom right and select “create system restore”
  8. Any other information (eg your guess regarding the cause, with reasons):Bug in software.

B. FILES APPENDED. (Please zip unless screenshots).:One Zip file atached + 1 screen shot.

  1. Screenshots of the Defense plus Active Processes List (Required for all issues):Incuded.
  2. Screenshots illustrating the bug: Not possible
  3. Screenshots of related CIS event logs:Attached
  4. A CIS config report or file: Attched
  5. Crash or freeze dump file: Does not crash or freez.
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Attched.

C. YOUR SETUP:Windows 7 Home Premium

  1. CIS version, AV database version & configuration: 5.9.22165.2197 AV Database 11377
  2. a) Have you updated (without uninstall) from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security levels: Defence+ Safe Mode Firewall Safe AV Security Stateful.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 Home Premium + Service Pack 1 and all updates up to 31/01/2012.
  7. Other security and utility software currently installed:Winpatrol, Sandboxie
  8. Other security software previously installed at any time since Windows was last installed:None
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:None

CIS does not interfere with System restore, my problem is when I install a program and CIS offers to make a system restore point via the popup window in the bottom right corner and I tick the option to create a System Restore point before installing any software No System Restore point is created ! if it is, it is not shown in the list of restore points in the Select a Restore Point to restore to.

I hope I have provided all the information requested.

Regards
John.

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

There is just one bit required information missing from your post:

  • The active process list. You appear to have appended the D+ events list not a screenshot of the active process list

We would be grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the format and here - if you need further help please ask a mod. If you do not add the information after a week we will forward this post to non-format. If this happens we will tell you how to rectify this if you wish to.

The reasons we may need these items of information when you may not think they are necessary are explained here

In the current process we will normally leave it up to you whether you want to make a report which meets all the criteria or not. We may remind you if we think a bug of particular importance.

Hi For some unknown reason your foum is not acepting Attachments! I tried several times and used Zip, Png
and nothing heppens when pressing the Post button.

Regards
John.

Working here as you can see.

With large files you sometimes have to wait a few mins if the boards are busy, sorry.

[attachment deleted by admin]

Does it give you an error message?

Sorry about missing the Active Proces list, If I may say so it is a very long converluted way of reporting a bug for the general publick ( I class myself as one). Could you not create a program to collect some of the information reguired ?

I have attched the Active process list as requested, I also install two programs today 03/02/2012 and CIS asked me what I wanted to do, I selected the greate system restore point and could not find the two restore points in the select system restore options.

I have had to split the Active proces list so there are two attached files.

Could not post with attachment via Ie9 had to use Comodo Dragon .
Regardes
John.

[attachment deleted by admin]

Yes automated data collection is needed, and mods have asked devs whether they can address this.

We understand it is being considered at present

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

:slight_smile:

As an example of why the Active Process List is needed, I see you are running Winpatrol, which possibly could be interfering with the creation of restore points - security software sometimes does! I would suggest uninstalling winpatrol, rebooting and see if that resolves the issue.

Also you are running sandboxie, which probably is not an problem but is worth considering.

Best wishes

Mouse

Hi I have removed the two programs you suggested may be causing the problem with system restore and have had Comodo Internet Security take more system restore points and I have seen no evidence when viewing system restore points via ■■■■ Cleaner of any restore points being taken when CIS asks if I would like to have CIS take one.

I have attached two more screen shots of the Active Process List.

Regards
John.

[attachment deleted by admin]

THanks very much for checking. Probably worth checking using the OS system restore tool to see if any restore points have been added instead of CC cleaner?

Hi Just checked Windows OS System Restore and there are no restore points made by CIS.

I look forward to you resolving this bug.

Regards
John.

Many thanks for checking this

So do I :slight_smile:

Mouse