CIS doesn't install

I’m a long time user of Comodo Personal Firewall, and discovered that there was a new version yesterday.

I downloaded the installer, and ran it.
After a 52 Mb download (I unchecked Comodo Hopsurf Toolbar), the installer appeared.
Here is what I do (it’s 100% reproducible):

Click Next.
Check to accept the terms.
Click Next
Uncheck Comodo Antivirus
Click Next (we keep the Firewall with Optimum Proactive Defense)
Check "I do not want to join the Threatcast community)
Click Next
Check I do no want to use Comodo Secure DNS Servers
Click Next
Uncheck the 2 checkboxes
Click Next
Click Install
The installation fails, with a message: CIS ended prematurely because of an error.

Since I’m a developer, I dug further.
I ran msiexec /i CFP_Setup.msi /log log.log
and searched for an error in the logs.
Here is the interesting part:

Property(S): OriginalDatabase = c:\ProgramData\Comodo Downloader\CFP_Setup.msi
Property(S): UILevel = 5
Property(S): Preselected = 1
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): SOURCEDIR = c:\ProgramData\Comodo Downloader
Property(S): SourcedirProduct = {CC6B1BB4-4E06-4A5B-A166-B371B551324B}
Property(S): ProductToBeRegistered = 1
Action ended 03:04:45: ExecuteAction. Return value 3.
Action 03:04:45: CisFatalError.
Action start 03:04:45: CisFatalError.
Action 03:04:45: CisFatalError. Dialog created
Action ended 03:04:47: CisFatalError. Return value 2.
Action ended 03:04:47: INSTALL. Return value 3.
Property(C): UpgradeCode = {B9D3F17C-97D2-4285-9964-BFD6ADFFE38F}

BTW, it seems that Comodo LivePCSupport has been installed and not uninstalled when I removed CIS 3.
Any idea of the problem ?

Edit: I’m running Vista 32 bits.

What happens when you uninstall Live PC support, reboot and try again?

Same thing.

I tried to install the MSI after uninstalling everything, and I still got the error.
I can provide the complete MSI log if you need it.

Edit: I forgot to add that I disabled UAC, since I’m a developer.


I stumbled over the same problem, and after some extensive research I could solve it.

There were two steps from which one or both are the solution:

  1. Delete the Infcache located at C:\Windows\inf\INFCACHE.1
  2. Run cleanup tool from here:
    Comodo Forum

I hope these steps help you to solve this problem to.