CIS doesnt install in the correct (non-default) directory [V6][M250]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: Happens everytime you install comodo firewall or internet security but change the install directory to something other than the default
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Install CIS, change the install directory to c:\program files\comodo\internet security\
  • If not obvious, what U expected to happen: CIS to install in the directory specified by the user
  • If a software compatibility problem have U tried the conflict FAQ?: N/A
  • Any software except CIS/OS involved? If so - name, & exact version: N/A
  • Any other information, eg your guess at the cause, how U tried to fix it etc: Bug in the installer
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware) Screenshots, diagnostics, killswitch processes attached
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: Comodo firewall or internet security 6.0.264710.2708, any config

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: d + disabled, firewall safe mode, BB partially limited, AV safe mode
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a previous version of CIS: No
    [li]if so, have U tried a a clean reinstall - if not please do?: N/A
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: N/A
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Windows 7 ultimate, sp1, x32 or x64, UAC disabled, Admin, No vm
  • Other security/sandbox software a) currently installed b) installed since OS: Clean install of windows so no other software installed.
    [/ol]

This has been a problem since v5

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

NOT fixed in CIS 6.1.276867.2813

Tracker updated, thanks

This is NOT fixed in v6.2.282872.2847

Thank you.

I have updated the tracker.

The devs have flagged this bug as Confirmed and Deferred. This means that they will eventually fix this, but at the moment there are many other bugs which must first be addressed.

I hope you understand and can coexist with this bug until they are able to fix it.

Thank you.

This is NOT fixed in v6.3.294583.2937

Tracker has been updated

Thank you.

i have been notified by QA that this is the expected behavior. it wont be changed for internal reasons. issue resolved