CIS does not start, diagnostics does not start. Network is completely blocked.

Some time ago (maybe a year or so) comodo started to complain that it has problems at startup, then it started diagnostics that couldn’t find anything. So it worked like this several month and to fix this I attempted to reinstall it. But it actually blocked my network completely and doesn’t start at all. So to fix my network I just uninstalled it(it was a year ago…).

Now I’ve tried to install it again . Right after installation it started and I was able to update antivirus database. But after reboot it shows me 2 identical messages that it will start diagnostics tool ,but nothing was started (and diagnostics tool window was not shown). And also my network was blocked. I tried to start CiS manually, but nothing happened. Also I found comodo services and tried to start them manually, but immediately got answer that there is no response from them.
Also I’ve tried to look into system events and I found in CIS related events
“Failed to get the class object for ClassFactory interface. Error Code: 0x8007041d”
…so I uninstalled it again to be able to use internet :slight_smile:
“Uninstallation Complete. We’re sad to see you go, please give us another try.”
Ok… lets give it another try. :slight_smile:
OS: Windows 7 x64. No other antivirus software is installed.
I also tried to search for similar problems, but I didn’t found clear solution, so decided to start new topic.

As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase . That provides a good starting point.