Cis does not register with Vista Security Center

Yes, other people are having this issue. There was another in the 4508 thread besides yourself, and then there’s me.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, 100% for me.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Boot computer
2:Look at Windows Security Center when the alert pops up in the tray
One or two sentences explaining what actually happened:
Windows Security Center reports that the Firewall is turned off, and that “COMODO Antivirus is on but is reporting its status to Windows Security Center in a format that is no longer supported.”
One or two sentences explaining what you expected to happen:
I expect Windows Security Center to believe that COMODO Firewall is active, and for it to be able to decode the messages from COMODO Antivirus.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I have rebuilt the WMI repository (as suggested earlier in the thread), and that verifies as consistent. The undesired behaviour remains, however.

Exact CIS version & configuration:
(I’m not sure what “configuration” is wanted beyond the modules in the next point)
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus: Stateful
Auto-Sandbox: Enabled
HIPS: Safe Mode
Viruscope: Enabled
Firewall: Safe Mode
Have you made any other changes to the default config? (egs here.):
I don’t think so.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
I don’t recall what the previous version was, I’m afraid; it would have been without an uninstall, though – CIS just prompted me to update and I did.
if so, have you tried a clean reinstall - if not please do?:
I have not yet done so; looking at instructions for that now.
Have you imported a config from a previous version of CIS:
Not explicitly; see previous point.
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows Vista Home Basic, SP2, 64-bit, UAC is on, account type is Administrator. No virtual machine is involved.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

Attached: Screenshot of Windows Security Center, Diagnostics file.

[attachment deleted by admin]

I split off a bunch of posts that and merged them with COMODO Internet Security problem on Vista [merged]. They are better suited there.

Hi Guys,

QA s will check the issue and I will inform you accordingly.

Kind Regards

Hey Guys,

On the backlog, will be fixed with the next version, for your kind information


but is CIS still providing protection even though it is not registering with the Win Security Center?


It is fully functional and fully protecting your computer. It is just the registration with the Windows Security Center that is the problem. You can fully trust what CIS reports its state; whether it is fully functional or not. Windows Security Center does nothing else then reporting what a program reports about its condition.