CIS does not download file for installation!

Hi all! I have a ver big problem. I did a format on my 1st laptop 4 days ago and i installed the last version of CIS (the red theme is awesomo!). Yesterday i did format to my other 2 laptops (one has win vista premium sp2, the other win xp but updated to latest updates from windows updates). I tried to install the cis and it had problem to download some files… i dont remember the files. so. today i tried to install only the firewall and the error i get is this:
“Cannot download file http:/download.comodo.com/cis/download/installs/xml_binaries/cis/cis_setup_x86.msi
Error 12002. Connection timed out. Try again?”

My connection is ok i have no problems! Also if i press to try again, it will start downloading from the beginning but when it reaches the 39.0 (of 39.1) it will stop for some seconds and will do the same. I have the problem with both laptops (xp and vista). I never had problem with previous cis products before.

Plz help me, i use many years the comodo CIS and firewall and i dont want to change it! Is the best firewall!

Are you using the on-line installer? If so, give the off-line installer a try. Smooth as silk AFTER you have uninstalled the old version:

http://download.comodo.com/cis/download/installs/xml_binaries/cis/cis_setup_x86.msi

οκ thx now it is ok, but when the online installer will be ok?