CIS does not asks to Restart if Deactivated permanently [NBZ]

The bug/issue

  1. What you did: clicked on Deactivate D+ Permanently then moved the slider to disabled then moved the slider in image execution to off and then disabled the sandbox and in last I finally clicked OK

  2. What actually happened or you actually saw: CIS didn’t prompted me to restart the system instead i manually Restarted

  3. What you expected to happen or see: CIS should have prompted to restart

  4. How you tried to fix it & what happened: Restarted the system and unchecked the Deactivaate D+ permanently ,it asked me to restart the system and on next boot I again Deactivated D+ permanently,this time it prompted me restart the system.

  5. If its an application compatibility problem have you tried the application fixes?: N/A

  6. Details (exact version) of any application involved with download link: N/A

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Can be repeated by following Step-1

  8. Any other information (eg your guess regarding the cause, with reasons): GUI error

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: N/A
  2. Screenshots of related event logs and the active processes list: N/A
  3. A CIS config report or file. Attached Config report in Zip
  4. Crash or freeze dump file: No Crash Ocuured

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142 signature database ver. 6465
  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: No
  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?: NO
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) NO
  5. Defense+ and Sandbox OR Firewall security level: Safe/enabled/Custom
  6. OS version, service pack, no of bits, UAC setting, & account type: Xp Pro/Sp3/32bits/NA
  7. Other security and utility software running: N/A
  8. Virtual machine used (Please do NOT use Virtual box):N/A

[attachment deleted by admin]

I can confirm this on Windows 7 x32 if you change any other settings like image or sandbox slider at the same time works both ways tick box or untick, you do not have a alert to restart.

I have to presume that in this case clicked on Deactivate D+ Permanently box fails and does not work, no UAC prompt either.

When you only tick the box and move the slider to disable Defense in Windows 7 x 32 LUA with UAC enabled you get a UAC prompt and then a alert to Restart.

Move to Format verified Issue Reports - CIS

Hi, aditya_dmj. Thanks for your feedback.