CIS disables network connection & removes profile on uninstall - AGAIN

In my first ever post many months ago now, i outlines the same issue im now having,…

This is really pissing me off…bad code

  • Fresh install of XP SP3
  • Network driver install - Atheros PCI Card in desktop PC (Not laptop)
  • Confirm connection to internet working - OK
  • Install CIS (Latest build)


  • Connection disabled
  • CIS obviously not working
  • Remove and reinstall Atheros driver, can be done without rebooting
  • No change
  • Attempt to remove CIS…reboot…and my user profile has been erased.

Now ive tried this twice tonight

Including doing my Windows Updates before CIS install the 2nd lime!!!

I complained baout this once before, and then a month or so later got an email sayng “try this build”, and lo and behold it worked.

'My mistake obviously was when reinstalling windows to update to the latest build…now completely useless again. Its my fault, i though a new version was actually supposed to be better and actually functional…

Perhaps if you spent more time actually focusing on the firewall code, which is all anyone who knows what theyre doing uses of this product, instead of bloating it with stuff i have separate programs for or adding “Pro” features, you’d actually have a usable product, and i wouldnt have to go through the yoyo of working/non-working every time you seem to update.

Once again ill have to alert everyone i know, and on who’s machines i put the last decent build on, not to update their Comodo firewall, ill go one better ill find them a replacement, because this is getting beyond a joke now. This is the 3rd time (and 4th actually) that youre software has disabled my network connections and then removed my user profile. Luckily im a diligent person who tests on his own PC before rolling software out. The implications of your uninstall routine removing user profiles in a small workgroup even are frightening!!

Im done, ill go back to using tried, true and old Sygate, if they had a more up to date version id even PAY for it, rather than suffer at the hands of Comodo again.

What a waste of my time

Perhaps its time you open sourced the code so someone other than the 13yo you currently have working on it can actually get it working…

EDIT: Just noticed a new version to the one i tried. For the record the one i have tried is:

Comodo Internet Security v3.9.76924.507

Which doesnt appear in the release notes list, its a phantom, probably because they new it was buggy and released it and got too many complaints and restrospectively erased any sign of it from the changelog…

Again, poor user treatment Comodo, very poor.

Exact same problem happened to my 3 times. Though COMODO completely ignored me. :-TD I have the same Atheros driver.


The insane thing is that last time i complained i got an email like 2 months later saying “try the new version”, and it worked

So why the backwards step now??

I suspect a fatal flaw in their NIC enumeration code or in their revision control system, because youre not supposed to (re)introduce old bugs…sheesh

When it works its easily the most manageable firewall…when its working…

The day they take out all the AV and HIP ■■■■ (and it is just ■■■■ bloat) the day they’ll get less users havng issues. When is a company with a great product (Comodo Firewall) going to resist the sheep like attitude of others and NOT try and bung extra features nobody wants into a product to try and be an all-in-one solution. Sane people like choosing their own AV and HIP software…i just want your firewall Comodo, preferably a working one with no other ■■■■ in it…remove the ■■■■, the bugs are easier to fix…simple

Ill even pay for a WORKING Firewall only product, and so would many many others.

But im sure you’ll just ignore this and cut your own throats…

This is quickly becoming the kind of ignore forum user fail that Creative put on this year with DanielK’s actually working drivers :slight_smile:

And we all know who won that encounter…and it wasnt Creative

expect to be ignored no, really, no need to apologise for the hours ive wasted , the raping of my user account or disabling of my network X 4 attempts…

Well 3.9 is working for me now, but yeah - COMODO made me pull my hair :-\

So how did you overcome it?

Or was it another 77Mb download to the latest one. were you like me, on the phantom older version?

3.8 was a disaster, but this issue was there even in CFP. I downloaded the latest .509 - works okay for now :slight_smile:

After a clean Vista SP2 install ofcourse ;D (I had to reinstall about 3 times till I figured it was CIS fault)

At least you didnt download the phantom v3.9.76924.507 release thinking it was THE LATEST. only to find it would kill your PC, and NOT appear anywhere on the Comodo website only days after downloading it.

Thats a special kind of dishonesty if you ask me, releasing something only to basically erase any reference to it. Nice going Comodo. Way to inspire confidence :slight_smile:

And heres a direct challenge to you, release a firewall ONLY product again, 77Mb+ is a JOKE, when Sygate and even up to date Sunbelt Personal Firewall are around 5Mb…

Bloatey Bloat Bloat

Answer the challenge, we dont want all that other ■■■■

Well the largest part is the antivirus in CIS, that’s why it takes so much space :slight_smile:

But I agree that CIS is buggy and a lot of bugs that were fixed come back in new releases :-TD

Well my issues are over, i reinstalled XP for the 5th time, connected to the internet, went to sunbelt and entered my VISA details.

After a 1min wait for the 5Mb Sunbelt Personal Firewall download, and another 5 minutes installing and getting it basically setup up, im happy as larry. Traffic throughput is spectacular. And i still have a working net connection and my user profile is intact!

Thanks again for the EPIC fail Comodo.

I expect a few more people will need to waltz out before you listen to the people who actually use your software…