CIS dialogs don't open and it hangs

I installed CIS a few days ago, it’s fully updated.

But all of a sudden its dialogs don’t open anymore. First time I noticed it I tried to open Settings and it didn’t work. Then I tried View Connections and nothing. After trying 1 or 2 times the whole main window hangs and goes unresponsive. Even its alert dialog hangs and I can’t allow/block a request.

If I reboot PC its main window goes back responsive, I can disable and enable antivirus and its alert dialog shows up. But if I try to open any dialog or answer an alert, it hangs again.

If it hangs by answering an alert, double click on systray or executing its start menu link doesn’t open its main window.

First, change your configuration to Proactive Security (see 1st attachment).
Then, disable the HIPS (see 2nd attachment), there were a bug about it.
If you want more details about how to set CIS at best, you can watch this video

Thanks a lot! I haven’t made enough tests yet but dialogs seem to be working now.

Any reference for this bug and when it will be fixed?

check reply #241 here;msg847680#msg847680

a new release should be out early on april, but i dont know if this bug will be fixed