CIS Diagnostics reports error that it can't fix [M938]

A. THE BUG/ISSUE (Varies from issue to issue)

[b]Summary - Give a clear summary in the topic subject, NOT here.[/b]
[b]Can U reproduce the problem & if so how reliably?:[/b]Yes, every time
[b]If U can, exact steps to reproduce. If not, exactly what U did & what happened:[/b]

1:Do a clean install of CIS.
2:Every time I run the diagnostics utility in CIS it reports that there is an error
3:However, it is not able to fix the error
If not obvious, what U expected to happen: that everything was ok and fine
If a software compatibility problem have U tried the conflict FAQ?: No, not a compatibility error
Any software except CIS/OS involved? If so - name, & exact version: None
Any other information, eg your guess at the cause, how U tried to fix it etc:
Even a clean install, with running the removal tools inbetween, does not solve this problem.
However, it did go away once after running a Rating Scan and KillSwitch. However, after doing a clean reinstall, I could not get it to go away, even after running a rating scan and KillSwitch. Thus, it is likely random in terms of whatever fixed it.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

Exact CIS version & configuration:
CIS Premium 7.0.313494.4115 with Proactive config
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: described above
Have U made any other changes to the default config? (egs here.): HIPS is off
Have U updated (without uninstall) from a CIS 5?: no
if so, have U tried a a clean reinstall - if not please do?:-
Have U imported a config from a previous version of CIS: no
if so, have U tried a standard config - if not please do: -
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Win7 Home Premium, SP1, 64bit UAC default (enabled)
Other security/s’box software a) currently installed b) installed since OS: a) none b) none

[attachment deleted by admin]

Please try reinstalling by following the methods I suggest here and let me know if the errors continue to be reported even after reinstalling this way. Be sure to run the removal tools in Safe Mode after uninstalling CIS normally.

Let me know how it goes.


I used those methods before I installed v7, I ran v6 before and did a clean install.

Okay. Please try once more though. It’s very strange to have an issue like this. Therefore, before forwarding it to the devs I have to be extra certain. I hope you understand.


Ok I just reinstalled and the issue still appears… Also my settings are at Default now and it still reports this problem…

Thanks. Please also attach a KillSwitch Process List to your first post. Then I will forward this to the devs for investigation.

I have attached my KillSwitch logs, what’s interesting now is that the issue seems to have disappeared only after I ran a rating scan and installed Killswitch through the watch activity. Though I still think this should be looked into. Here is my new CIS report file attached.

[attachment deleted by admin]

That is very strange. If you don’t mind, could you try reinstalling by following the methods I suggest here. Then, after reinstalling, see if the errors appear again. If they do, see if running the rating scan does in fact fix this issue.

If it does then we will have much better information to pass on to the devs.


I reinstalled and the issue still persists, even after running a rating scan and installing killswitch. I have attached my new CIS report, maybe a Comodo Dev can compare it to the last one i posted where the issue was fixed.

[attachment deleted by admin]

I checked, and I also have a diagnostics report which shows errors it cannot fix. Thus, I may have the same problem.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Thank you, also if you are experiencing the same issue does it mean that CIS is corrupt or it is just a false message and CIS is working fine?

I’m not sure, but I have passed this on the developers for investigation. Hopefully they will be able to reproduce this and sort out whether there is real corruption or if it is a false alarm.


Not fixed in 7.0.315459.4132

Thanks for checking this. I have updated the tracker.

FYI, I do not have this problem. “Diagnostics did not find any errors” and a green checkmark. 7.0.315459.4132

Fixed in 7.0.317799.4142, Thanks Comodo Devs :slight_smile:

Thanks for checking this. I’m happy to hear it’s now fixed. I have closed this entry in the tracker and will move this report to Resolved. If the issue returns please let me know.

Thank you.