CIS deletes wrong configuration profile [V6][M678]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes. I can be reproduced.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

[li]Install Windows 8.1

  • Install CIS 6.3
  • Open Advanced Settings and navigate to Configuration
  • Optional: Import an additional configuration – just for testing.
  • Select one of the three configurations (“COMODO - Firewall Security”, “COMODO - Proactive Security” and “COMODO - Antivirus Security”) and issue a delete command. CIS reports it is deleted. It goes off the list.
  • Select a second profile and issue a delete command. CIS reports deletion failed. Any subsequent attempt to delete anything means an error message.
  • Exit the Advanced Settings dialog box. The wrong configuration is in effect. CIS deleted something but that wasn’t what it was told.
  • Open Registry Editor and navigate to HKEY_LOCAL_MACHINE\SYSTEM\Software\COMODO\Firewall Pro\Configurations. Observe that all configuration profiles are intact; only somehow, CIS doesn’t show them.
    From there I can delete or activate whichever I wish. In one case I found six configs there, from 0 to 5.
    [/li]- If not obvious, what U expected to happen: N/A
  • If a software compatibility problem have U tried the conflict FAQ?: N/A
  • Any software except CIS/OS involved? If so - name, & exact version: None.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: See here:

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.3.294583.2937 and later , all configurations, including 6.3.301250.2972

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Firewall=Default, AV=not installed, others=default
  • Have U made any other changes to the default config? (egs here.): No.
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: N/A
    [/li]- Have U imported a config from a previous version of CIS: Occurred both with and without doing so.
    [li]if so, have U tried a standard config - if not please do: Yes. Occurred regardless.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: (Windows 7 SP1, real computer), (Windows 8.1 IA-32, UAC Enabled, admin account, checked with VMware)
  • Other security/s’box software a) currently installed b) installed since OS: None

A video of this issue can be downloaded from here:

[attachment deleted by admin]

Please also attach a process list for the computer this is occurring on.

Also, can you confirm that this is still occurring with CIS version 6.3.301250.2972?
Also, have you experienced this on your real computer, or just on the Virtual Machine?



I confirm. Diagnostic report and process list attached.

Yes. How else could I have discovered it? Attaching actual system reports now…
Also see this:
You might be able to get yet another report

[attachment deleted by admin]

I have captured the bug on video. Here is a link:

Since this video is captured on a new machine, I’ve attached its reports too. (Video capture on VMware is impossible and on the actual machine, capturing must stop between restarts, so, it can’t be done reliably.)

[attachment deleted by admin]

Thank you very much. I think there is more than enough here to forward this to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have informed me that they believe that this is fixed for CIS version 7.0.313494.4115. I will therefore move this to Resolved.

If this is still not fixed for you please both respond to this topic and send me a PM (including a link to this bug report).

Thank you.