CIS database updating

Lately occasionally in Win 7 pro 64bit CIS hasn’t been able to update database even it should update db every hour until comp is rebooted and then CIS can update itself w/o problems until CIS bugs again (no updating issue in Vista) week or 2 later.

Can you reproduce the problem & if so how reliably?
Yes but it takes a week or 2 until it happens again.

If you can, exact steps to reproduce. If not, exactly what U did & what happened:
Checked CIS and database was 18 hrs old (this time, last time 3 days (which CIS reported to user its own way)) and when tried to update installing signatures gives error (until next reboot).

One or two sentences explaining what actually happened:

CIS database was older than 2 hrs and normal database update didn’t work until rebooted computer.

One or two sentences explaining what you expected to happen:

CIS should have updated its database automatically.

One or two sentences explaining what you expected to happen:

When pressing update button CIS should have updated outdated database.

If a software compatibility problem have you tried the advice to make programs work with CIS?:

No compatibility problems.

Any software except CIS/OS involved? If so - name, & exact version:
Not that I know.

Any other information, eg your guess at the cause, how you tried to fix it etc:
None except for some reason CIS puts cmdvirth.exe in sandbox.

Exact CIS version & configuration:
Comodo Internet Security version

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV set to block threat, heuristics set to high, Cloud AV off, Firewall set to Safe Mode.

Have you made any other changes to the default config? (egs here.):
Nothing major.

Have you updated (without uninstall) from CIS 5, 6 or 7?:

 [b]if so, have you tried a a a clean reinstall - if not please do? [/b]

No, don’t have nothing to do, it’s a version bug and it wouldn’t solve problem since CIS “fixes” error after reboot until next time.

Have you imported a config from a previous version of CIS:

[b] if so, have you tried a standard config - if not please do:[/b] Config is standard.

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 pro 64 bit SP1, UAC on, normal account.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a) Spybot b) Spywareblaster

[attachment deleted by admin]

you have seemed to use an old bug report format, i have gone through and edited your format using the new updated version. However there are a few things missing. Can you please answer the questions that are marked with a “?”



  1. Please try a clean re-installation. #guide
  2. Please check with version <>.
  3. Try to import latest definitions manually.
    ( )

I might try clean install when CIS bugs again. Installing CIS and making settings same as before is bit pia.

Also, if it doesn’t work try the following :

  1. cmd > netsh winsock reset ;
  2. restore router default settings (MTU, TCP MSS).

Hope it helps.

Its not problem in my netconnection, its problem in CIS.

PM sent.

Just joined the forum.
After CIS update, EVERY BOOT, the antivirus update is GONE, and it says not updated for like 27 days!
Removed CIS, reinstalled from scratch - same problem !!!
Win7 PC.
Working win Comodo CIS for the past 5~6 years, NEVER such a problem (previously winXp)

For me its even worse, no updates working at all on fresh install of CIS and Firewall ed. (can’t connect to server)
Seems like a very bad omen for a Security Software ??
OS is Win 10 pro


It’s kind of hard to tell without a diagnostics report if you’re experiencing the same issue. Please attach a diagnostics report.

I’ve been informed by the OP trough PM that the issue did not manifest for a long period of time / can no longer be replicated.
Thus, I will move this one to “Resolved” section.