CIS crashing regularly since last update

Hi there!

I tried to find somewhere to put this, and with all the restrictions on bug reporting I didn’t want to put it there, but none of the help sub-fora contained my issue.

I also would have submitted a support ticket, as I have done in the past, but currently doesn’t really exist – a bad way to support users when things like this happen.

Since I updated my comodo software ~3 days ago, comodo has been crashing 2-3 times/day, causing me serious headaches and worries about my system security, and has also forced me to need to reboot my computer repeatedly – 1-2x/day rather than the 2-4x/month it used to be rebooted.

I am running winXP pro x64 on an AMD athlon II x4 635 with 8gb ram in ganged mode.

I have plenty of hard drive space.

I also installed privdog, as it was offered during the installation, and on research I decided it would be a good thing to have, and clearly comodo was vouching for it.

I use mozilla firefox for web browsing and thunderbird for email.

My experience with the in-line update has been abominable; even clean install of v7.0.x was a nightmare. What I found works best was to export v5.12 config, clean install of v6.3, import v5.12 config, activate custom config, allow initial scan to complete and then reboot. Subsequently accommodate new alerts as appropriate by allow only, i.e., w/ out remember this alert option ticked. Maintain rules for FW & D+ in advanced configuration UI and update all rules for apps in one fallen swoop.

Subsequent in-line upgrade to v7.0.x went pretty much w/ out hitch.

You should be aware that the CIS default file-group now contains the following:


If one has custom FW / D+ rules for CIS, the last item listed above will be of importance. Create a new rule reflecting the new file name, and copy the rules from pre-exising CmdUpdat The old FW rule can then be deleted.

You’ll need D+ rule for %PROGRAMFILES%\AdTrustMedia\PrivDog*\TrustedAdsSvc.exe

w/ two COM interfaces, i.e., %windir%\explorer.exe & %PROGRAMFILES%\AdTrustMedia\PrivDog*\trustedadssvc.exe

w/ DNS Client Service + FW rules to allow access to DNS servers

The above rule implements wild card in the path to address version changes. Moreover, a D+ rule for


w/ COM interface: %SYSROOT32%\svchost.exe
FW rules to access DNS servers

is necessary.

%SYSROOT32% = %windir%\system32
%USR_LOCAL_APPDATA% = %USERPROFILE%\Local Settings\Application Data

My recommendation post install of newer version: do not utilize remember this option; utilize the logs and maintain the appropriate ALL the rules for any arbitrary app all at once, then hit o.k. (you can maintain both FW & D+ as necessary and then hit o.k. to update the config). I found it works well that way; otherwise there’s just to much delay until the system UI has 100% control. In the meantime there can be numerous alerts in queue and that can play havoc with system response and what not.


As I don’t have any of those old versions of comodo, and have been working flawlessly with the current version of comodo until this most recent update, I’m leery of attempting such a complicated procedure.

I think I’m more interested in doing a proper uninstall of comodo and then a clean, fresh install with the current version, as that worked fine for me last time; however, I don’t want to lose all my settings and configurations for all my software. Is there any way to export or save all my custom rules and application settings? And then I can follow the instructions for a full removal and reinstall and then re-import my settings.

And why, by the way, does comodo ask me if killswitch should be allowed access to the internet? I expected the sw to whitelist all its own components at least!

And also, since this just came up – why is killswitch not listed in the start menu? I just had to drag it there so I’d have access to it without either having to open comodo proper or having to replace task manager. At first I replaced task manager, but then killswitch hung on start, and the only way to recover was to use my reset button, as I couldn’t get at task manager any more and the regular turn off computer → shutdown wouldn’t work due to the hung killswitch.

Actually, found my answer while reading the forum to see if there was any insight I could use.

Any further advice? Must finish some other things before I start this process.

Thank you!


As always make sure there are no leftovers of security programs you had installed in the past. A possible left over can cause all sort of “strange effects”. Please run clean up tools for all security programs you had in the past. A list can be found here at the Eset website: ESET Knowledgebase .