CIS crashed while adding file to AV exclusions. [294]

The bug/issue

  1. What you did: After installing CIS with AV & Firewall i updated AV and before doing a scan i remembered
    that it always flagged two files, one being CLT . I opened AV and added CLT to exclusions
    but couldn’t remember name of other file, hence opened explorer, found file and AV opened
    saying file suspicious, i added to exclusions.
  2. What actually happened or you actually saw: CIS crashed.
  3. What you expected to happen or see: File added to exclusions.
  4. How you tried to fix it & what happened: Nothing.
  5. If its an application compatibility problem have you tried these fixes: N/A
  6. Details (exact version) of any application involved with download link: N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes see below.
  8. Any other information (eg your guess regarding the cause, with reasons): guess it didn’t like adding file to exclusions when exclusion tab open in AV.

Files appended

  1. Screenshots illustrating the bug: None.
  2. Screenshots of related event logs or the active processes list: None.
  3. A CIS config. report or file: None.
  4. Crash or freeze dump file: Attached.

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.162636.1135, 6409, Internet Security config
  2. Have you updated (without uninstall) from CIS 3 or 4, if so have you tried reinstalling?: No, N/A
  3. Have you imported a config from a previous version of CIS, if so have U tried a preset config?: No, N/A
  4. Defense+ and Sandbox OR Firewall security level: Defenseplus=Safe, Firewall=Safe, AV=Stateful, Sandbox=enabled
  5. OS version, service pack, bits, UAC setting, & account type: Win 7 x64 Pro, Windows Firewall and UAC disabled, all updates, admin.
  6. Other security and utility software running: No other real time AV or Firewall.
  7. Virtual machine used: Not applicable

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Mouse] here[/url].

Thanks for an excellent bug report.

Sorry to trouble you further, but for the devs to address this sort of bug they will need a crash dump file (guidance here) unless you can make the crash happen again, in which case they will need a precise description of how to make it happen again.

Many thanks in anticipation.

Best wishes

Mouse

No Windows dump but CIS was attached above. I repeated what i did and CIS crashed again.
new CIS dump attached.

The bug/issue

  1. What you did: I opened CIS AV, Scanner Settings, exclusions (leave open), open windows explorer, go to file that i know will bring up CIS AV real time warning that file is suspicious, warning pops up, goto options add to exclusions. Close explorer. Look in open exclusions tab and file not there. Click OK and CIS crashes.
  2. What actually happened or you actually saw: CIS crashed.
  3. What you expected to happen or see: File added to exclusions.
  4. How you tried to fix it & what happened: Nothing.
  5. If its an application compatibility problem have you tried these fixes: N/A
  6. Details (exact version) of any application involved with download link: N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes this is second occurance - steps to replicate under ‘What you did’ above.
  8. Any other information (eg your guess regarding the cause, with reasons): guess it didn’t like adding file to exclusions when exclusion tab open in AV.

Files appended

  1. Screenshots illustrating the bug: None.
  2. Screenshots of related event logs or the active processes list: None.
  3. A CIS config. report or file: None.
  4. Crash or freeze dump file: Attached.

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.162636.1135, 6421, Proactive Security config
  2. Have you updated (without uninstall) from CIS 3 or 4, if so have you tried reinstalling?: No, N/A
  3. Have you imported a config from a previous version of CIS, if so have U tried a preset config?: No, N/A
  4. Defense+ and Sandbox OR Firewall security level: Defenseplus=Safe, Firewall=Safe, AV=Stateful, Sandbox=enabled
  5. OS version, service pack, bits, UAC setting, & account type: Win 7 x64 Pro, Windows Firewall and UAC disabled, all updates, admin.
  6. Other security and utility software running: No other real time AV or Firewall.
  7. Virtual machine used: Not applicable

[attachment deleted by admin]

Thanks very much for doing that, and for you excellent bug report.

Forwardingto fomat verified now

Best wishes

Mouse